The resources of a Self Help project


Resources are objects created in a Self Help project and they can be used by all procedures in this project. Objects can therefore be modified in a single place and automatically updated in all procedures where they are used.

  • Resources can be images, PDF documents, HTML content, forms, etc.  Open url.png See Types of resources.
  • They are opened in edit mode in the Studio.
  • They are managed via a content validation workflow to ensure the progress of content up to the publication of the Self Help project.
  • They can be:
    • Added as an attachment in the step. In this case, their layout is automatically managed by the skin associated with the procedure.
    • Inserted in the HTML content of the step. In this case, you can customize their layout.

Notes

  • You can use resources only in procedures belonging to the current Self Help project.
  • To use resources from another Self Help project, you should create an archive and use the import and export functionalities. Open url.png See the procedure.
  • When you delete a resource in the content editor of a step, this will remove the resource from the step. It will not delete the resource from the Self Help project.

Best Practice

  • If the Self Help project contains numerous resources:
    • Create a Shared Resources folder at the root of the Self Help project and group the resources common to all procedures.
    • Create one Resource folder in each Self Help project subfolder, near the procedures using these resources.
    • Within each Resource folder, create subfolders to group each type of resource. We recommend that you use the same names in each folder.

      example  Icons, Forms, HTML content subfolders

  • Give a different name to each resource so you can identify it easily.
  • Define the naming convention for all resources in your Self Help project.
    • Naming rules: The resource name usually starts with the letter indicating the type of resource, followed by a short description of the related procedure.

      example  

      • Form resource associated with the Configure Outlook procedure ==> F_outlook_xxx
      • Image resource associated with the Send an email procedure ==> I_email_xxx
    • Writing rules: Case type used, e.g. lower or upper case

      example  CamelCase or snake_case

Types of resources

    Open url.png See the procedures:

Type Description
Documents
  • This resource can be an image, video, PDF, etc.
  • The properties of a document inserted in a step (not as an attachment) can be modified in the Description pane > Content tab of the step. Right-click the document name. Open url.png See the procedure.
  • You can define input and output parameters. Open url.png See the description.

Note: Authorized video formats are Flash files (SWF and FLV) or HTML5 files (OGV, MP4 and WEBM), with the restrictions below depending on the Web browser.

Web browser MP4 OGV WebM
Firefox No Firefox 3.5+ Firefox 4+
Internet Explorer Internet Explorer 9+ No If codecs are installed
Google Chrome Google Chrome 4-16 (not supported by earlier versions) Google Chrome 4+ Google Chrome 6+
Safari Safari 5+ No No
HTML content
  • Resources can associate text, tables, images, multimedia files, etc.

    Note: An image can contain clickable areas. Users can click these areas to run an action, such as opening a Web page, going to the next step, redirecting to a branch of the tree, etc. Open url.png See the procedure

    .
  • The content is saved as a HTML file.
  • You can define input and output parameters. Open url.png See the description.

Best Practice icon.png

  • Create HTML content for displaying the same header or footer containing versioning information or contact details in all procedures.

  • Place this resource in the Shared Resources folder.
Links
  • This resource is used to redirect users to a website or email server.
  • Links can contain visibility options.
Forms
  • This resource enables interactive data entry to obtain information from users. The information collected can then be used in the procedure steps.
  • You can define input and output parameters. Open url.png See the description.
Connectors
  • This resource provides access to a third-party service, e.g. Web service, email server, spreadsheet, etc.
  • You can define input and output parameters. Open url.png See the description.

Best Practice icon.png When exiting an action step that integrates a connector:

  • Check the error output parameter. If the call to the connector did not work correctly, then it will return an error code.
  • Create two or more conditional branches after the step. One of these branches will be used to process the different error occurrences.

Properties of resources

         Explorer Pane - Properties view - Resource.png

Access: Edit mode in the Studio > select the resource in the tree structure of the Explorer pane > Properties view. Open url.png See the description.

ExplorerPane_ResourcePropertiesView_Tabs

List of tabs

  • Info: Information on the resource, i.e. creation date, last modification date, location, size, etc. Note: You cannot change this information.
  • Linked Resources (Note: Only for HTML content resources): List of resources linked to the resource.
  • Variable (Note: Only for Form resources): Properties of the variable.
    • Click the link to display the steps where the variable is used.
  • Used by: List of steps using the resource, for each procedure.
    • Click <Open procedure and show the steps this resource is linked to>. The list of steps using the resource will appear for each procedure. Click one of the steps to display the procedure in the Conception pane and highlight the step.

Procedures

How to create a resource

See the detailed step-by-step procedure in Self Help.

Step 1: Select the Self Help project.

1. Select the Self Help project in the tree structure of the Explorer pane to be associated with the resource.

2. Click Tree expand icon.png to display the tree structure.

Step 2: Create the resource.

1. Right-click the folder where you want to create the new resource.

Best Practice icon.png Create one subfolder for each type of resource.

          Insert new resource.png

2. Select New from the contextual menu and click the type of resource you want to add. Open url.png See the description of the different types of resources.


3. Define the resource based on its type. Click below to see instructions.

Document

1. Select New > Document from the contextual menu.

2. Name the resource.

3. Click Browse to select the associated document.

4. Click Finish.

HTML content (text)

1. Select New > Content from the contextual menu.

2. Name the resource and press < Enter > to validate.

A HTML file associated with the resource will automatically be generated.

3. Double-click the resource in the Explorer pane.

The Conception pane will appear without any content.

4. Define the content of the HTML file in the Conception pane.   Open url.png See Conception pane for HTML content resources

.
  • To add text:
    • Insert the text you want.
    • Define the layout using the toolbar.
  • To add images:
    • Click and drag the required files located on the local machine or on your server from Windows Explorer to the Conception pane.
    • (optional) Select Images > Add clickable area from the contextual menu of the image. Open url.png See the procedure.
  • To add tables:
  • Click and drag the resources you want to add from the Explorer pane to the Conception pane.

The HTML file will automatically be saved each time content is added or modified.

Link

Form

Connector

This resource is inserted in the Explorer pane in the selected Self Help project and folder.

How to use a resource in a procedure step

Step 1: Select the step in the procedure. 

1. Double-click the procedure in the Explorer pane.
The procedure will appear in the Conception pane.

2. Click the relevant step in the Conception pane.
The Description pane will be refreshed.

Step 2: Select the method for adding the resource.


Resource added as an attachment in the step

Note: In this method, the skin associated with the procedure automatically manages the layout of the step.

See the detailed step-by-step procedure in Self Help.

1. Click and drag the resource from the Explorer pane to the selected step in the Conception pane.

  • The icon indicating the type of resource added will appear in the outline of the step.
             Conception Pane - Procedure - Step with resources.png
  • The resource will be added to the tab specific to the type of resource in the Description pane. Open url.png See the description of tabs.


Resource inserted in the content editor of the step

See the detailed step-by-step procedure in Self Help.

1. Insert the resource in the content editor of the step.

  • Click and drag the resource from the Explorer pane to the Description pane > Content tab. Place it at the spot where it should appear on the Web page.

    or

  • Go to the Description pane and select the Content tab.
  • Place the cursor at the spot where the resource should appear on the Web page.
  • Select Insert > Insert resource icon.png.
  • Select the resource you want.
  • The content of the resource will appear in the editor. For Document resources, a box will surround the resource at the spot where it is placed.
             Description Pane - Area for resource.png
  • The tab specific to the type of resource will be refreshed in the Description pane. Open url.png See the description of tabs.

2. Configure the resource.

  • Click the resource or click the box surrounding the resource.
    A contextual menu will appear.
             Insert resource contextual menu.png
  • Configure the resource using the context-specific options.

3. Define the layout.

4. (optional) Preview the step as it will appear on screen.

  • Click the step in the Conception pane.
  • Click Launch procedure dropdown list.png in the toolbar and select Launch procedure icon.png Launch the procedure.

How to view the use of resources in procedures

Which resources are using a given procedure?

1. Select the procedure in the Explorer pane.

2. (optional) Display the Properties view by selecting View > Properties in the menu.

3. Select the Uses tab in the Properties view.
 

Which procedures are using a given resource?

1. Select the resource in the Explorer pane.

2. (optional) Display the Properties view by selecting View > Properties in the menu.

3. Select the Used by tab in the Properties view.

How to modify a Document resource

Modify the document content

See the detailed step-by-step procedure in Self Help.

1. Select the Self Help project in the tree structure of the Explorer pane.

2. Right-click the document to be modified and select Open from the contextual menu.

3. Make the required modifications.

4. Save the document.
The content of the document will automatically be refreshed in all procedures using it.
 

Replace the document

1. Select the document in the tree structure of the Explorer pane.

2. Display the Properties view by selecting View > Properties in the menu.

3. Click Replace file icon.png in the toolbar.

4. Click Browse in the Replace content dialog box to select the new document.

4. Click Finish.
The existing document will automatically be replaced with the new document in all procedures using it.

How to export and import resources from one Self Help project to another

See the detailed step-by-step procedure in Self Help.

Step 1: Export the resources from the source Self Help project to an archive.

1. Select the Self Help project containing the required resources in the tree structure of the Explorer pane.

2. In the tree structure, press and hold < Ctrl > while selecting the resources to be included in the archive.

3. Right-click the last resource selected and select Export > Export as EV Self Help archive from the contextual menu.

4. (optional - if linked resources are opened) Click Yes if the following message appears: "There are opened editors associated with this Self Help project".

5. Specify the name of the archive and its location in the Export dialog box.
The archive containing the source Self Help project resources will be created.

Step 2: Import the archive of resources to the target Self Help project.

1. Select the target Self Help project in the tree structure of the Explorer pane.

2. Click Tree expand icon.png to display the tree structure.

3. Right-click the folder where the resources should be imported and select Import from the contextual menu.

4. Select the archive containing the resources to be imported in the Import Self Help projects or resources dialog box.

5. (optional) Select the status of the resources.

6. Click Finish.
The archive will be unzipped. The resources from the source Self Help project will be added to the Explorer pane for the target Self Help project.

Tags:
Last modified by Unknown User on 2020/03/24 12:36
Created by Administrator XWiki on 2018/12/14 11:21

Shortcuts

Powered by XWiki ©, EasyVista 2020