Studio Desktop de Self Help - Le mode Publication


Le mode Publication permet d'accéder aux versions publiées des projets Self Help du domaine actif.

Il donne accès à un ensemble de volets permettant de :

  • organiser les projets Self Help ;
  • créer une nouvelle version à partir d'un projet Self Help publié.

Remarques

  • La numérotation des versions est automatique et permet d'identifier leur nature :
    • version majeure : version planifiée.
    • version mineure : correction d'anomalies et de bugs.
               exemple  Version majeure v3.0 / Version mineure v2.1
  • Une version peut être créée uniquement à partir d'une version active du projet Self Help.
  • Les versions publiées peuvent être activées et désactivées individuellement.
  • Les versions non publiées sont accessibles via le mode Édition, dans lequel elles peuvent être modifiées.

Bonnes pratiques

  • Positionnez les volets suivant vos habitudes de travail.
  • Effectuez les publications de versions en différé pour éviter le ralentissement du serveur  - Open url.png voir procédure Comment publier un projet Self Help

Description de l'écran

    Studio mode - Publish.png

Accès : via le menu Mode > Publication

Dans sa configuration standard, le mode Publication affiche 3 zones :

Barres de titre et de menu

BarsDescription

    Studio - Bars.png

(1) Barre de titre : Informations de la session Self Help en cours (nom du serveur, domaine, utilisateur connecté).

(2) Barre de menu (Note : Certaines options de menu sont également accessibles via un menu contextuel disponible sur les composants du volet Explorateur).

Description de la barre de menu

Menu Fichier : Commandes permettant de :

  • créer un nouvel objet ;
  • importer une archive dans le domaine / exporter un projet Self Help dans une archive ;
  • publier un projet Self Help ;
  • changer l'adresse e-mail et le mot de passe du rédacteur connecté au Studio Desktop ;
  • changer de domaine.
     

Menu Édition : Commandes permettant de :

  • annuler / rétablir des modifications ;
  • copier-coller du texte ;
  • renommer / supprimer un objet.
     

Menu Procédure (Note : Uniquement si une procédure est affichée dans le volet Conception) : Ensemble des commandes permettant d'agir sur les étapes d'une procédure.

Menu Vue : Liste des vues disponibles dans le volet Explorateur et dans le volet Description.

  • Cliquez sur une vue pour l'afficher, ou non.
  • Les vues actives sont mises en évidence par leur icône affichée sur fond bleu.
  • Le volet Explorateur comprend 3 vues : Explorateur, Propriétés, Vue d'ensemble.
  • Le volet Description comprend une vue par langue disponible pour le projet Self Help courant  - Open url.png voir Description
     

Menu Mode : Liste des modes disponibles dans le Studio Desktop. Le mode actif est mis en évidence par son icône affichée sur fond bleu.

  • Mode Édition : Accès à l'ensemble des versions en cours de modification des projets Self Help du domaine actif  - Open url.png voir Description
  • Mode Publication : Accès à l'ensemble des versions publiées des projets Self Help du domaine actif  - Open url.png voir Description
  • Mode Administration (Note : Uniquement pour les administrateurs du domaine et les propriétaires des projets Self Help)  - Open url.png voir Description
     

Menu Aide : Commandes permettant de :

  • accéder à la documentation montrant le fonctionnement du Studio Desktop au travers de pas à pas détaillés  - Open url.png voir Description
  • revenir sur la page d'accueil de Self Help ;
  • définir les préférences :
    • utilisateurs créés par SSO visibles dans la liste des utilisateurs, via l'option Configuration de leadministration (Note : Fonctionnalité accessible uniquement à un administrateur domaine ou système) ;
    • sélection des langues pour la traduction ;
    • sélection des programmes à utiliser pour ouvrir les documents, lorsque différents de ceux utilisés par le système d'exploitation ;
    • configuration par défaut des macros.
  • afficher le journal des erreurs ;
  • consulter la version du serveur et du Studio Desktop.

 

Le volet Explorateur

Il affiche, via une arborescence, l'ensemble des projets Self Help du domaine actif, pour lesquels des versions ont été publiées.

Affichage du volet : menu Vue > Explorateur
         Publication - Explorator Pane.png

La barre d'outils

  • Select language drop down.png : Sélection de la langue d'affichage des composants du volet Explorateur.
    • Pour ajouter une langue dans la liste : menu Aide > Préférences > Langues autorisées.

L'arborescence d'un projet Self Help

  • Ouvrez l'arborescence en double-cliquant sur le nom du projet Self Help ou via Tree expand icon.png.
    • Les composants sont regroupés dans des dossiers.
    • L'icône affichée devant chaque composant identifie sa nature : procédure, variable, formulaire, ...  - Open url.png voir Contenu d'un projet Self Help
  • La version du projet Self Help est indiquée entre parenthèses, après son nom.
  • L'icône affichée derrière le nom de la version indique :
    • Property OK icon.png : une version active ;
    • Property NOK icon.png : une version inactive.
  • Les versions actives :
    • sont accessibles via une URL aux membres des groupes de publication ;
    • permettent de générer de nouvelles versions de rédaction (mineure / majeure).
  • Cliquez droit sur un composant : le menu contextuel affiche les actions autorisées  : création, copie, déplacement, importation, ...
  • Cliquez droit sur une version pour créer une révision mineure / majeure.
  • Le dossier Corbeille contient les versions supprimées des projets Self Help.

 

Le volet Propriétés

     Publication - Properties Pane.png

Procédure : Comment créer une nouvelle version d'un projet Self Help

Voir le pas à pas détaillé dans Self Help

Étape 1 : Création de la nouvelle version mineure / majeure

1. Ouvrez le studio en mode Publication (menu Mode > Publication).

2. Ouvrez l'arborescence du projet Self Help via Tree expand icon.png dans le volet Explorateur.

3. Cliquez droit sur une version active du projet Self Help, identifiée par Property OK icon.png, et sélectionnez Créez une nouvelle révision majeure /mineure dans le menu contextuelle.
La boîte de dialogue Édition d'une révision est ouverte.
 

Étape 2 : Informations de planification de la version

  • Soit lancez immédiatement la création via l'option Exécuter maintenant.
  • Soit différez la création via l'option Retarder l'exécution le :
    • Renseignez le jour et l'heure de lancement.

La nouvelle version est affichée dans le volet Explorateur.

Tags:
Modifié par Utilisateur inconnu le 2022/05/04 11:21
Créé par Administrator XWiki le 2019/12/09 19:41

Raccourcis

L'actualité mensuelle
•  Newsletter

Tous les changements
•  Service Manager
•  Service Apps
•  Self Help
•  Service Bots

Powered by XWiki ©, EasyVista 2021