Self Help - The Publishing Manager


The publishing manager comprises a set of dedicated panes for:

  • managing published versions of projects;
  • creating a project version from a published project.

It is accessed from the Publish view in the view bar of the Product name - ev Self Help.png application.

Notes

  • The version numbering identifies the version nature:
    • major version: scheduled version.
    • minor version: anomaly and bug correction.
               Example documentation icon FR.png : major v3.0 / minor v2.1
  • A version can be created only from an active version of the project.

Best Practice big icon.pngBest practice

  • Arrange your panes according to your work habits.
  • Carry out your version publishing off-line (in deferred mode) to avoid server slowdown  - Open url.png see the How to publish a project procedure

Screen description

In the standard configuration, the version manager displays 3 areas:

        SelfHelp - Publication Management.png

Title bar, menu bar, toolbar, view bar

       Publication - Bars.png

BarsDescription
  • (1) Title bar: Information about the current Product name - ev Self Help.png session (server name, domain, connected user).
  • (2) Menu bar
    • Certain menu options can also be accessed from the toolbar and from a context menu on the Explorer pane components.
  • (3) Toolbar
  • (4) View bar
    • Click a view to open it; the active view has a gray frame.
      • GUI - Bars - Other view icon.png : Access to customized views.
      • Edit view: Graphic editor for versions with ongoing project modification.
      • Publish view: Publishing manager for the published versions of projects.
      • Admin view: administration manager only for the domain’s administrators and the project owners.
          
    • Right-click a view name to display the contextual options:
      • Customize...: To select the items to be shown in the toolbar, the menu bar, commands and shortcuts.
      • Save as...: The changes made to the active view are saved under another view name.
        To revert to the standard view (default), click GUI - Bars - Other view icon.png > Other... and select it from the list.
      • Reset: Revert the panes of the active view to the standard display.
      • Close: Close the active view.
        To display the view again, click GUI - Bars - Other view icon.png > Other... and select it from the list.
      • Dock on: To set the view bar position (top left/right or on the left side of the graphic editor).
      • Show text: To display or not display the title of the view to the right of the icon.

 

Explorer pane

It displays all the projects in the active domain, for which versions have been published, as a tree structure.

Display pane: View > Explorer
         Publication - Explorator Pane.png

Toolbar

  • Select language drop down.png: Select the display language for the Explorer pane components.
    • To add a language in the list: Help > Preferences > Allowed Languages.

Project tree structure

  • Expand the tree structure by double-clicking the project name or click Tree expand icon.png.
    • The project components are grouped together in folders.
    • The icon shown opposite each component identifies its nature: procedure, variable, form, etc.  - Open url.png see Project contents
  • The project version is shown in brackets after its name.
    • Only published versions are shown in the publishing manager.
      • Property OK icon.png : active version of the project.
      • Property NOK icon.png : inactive version of the project.
    • The active versions:
      • can be accessed by the members of the publishing groups via a URL;
      • can be used to generate new revisions (minor/major).
    • The unpublished versions can be accessed from the graphic editor in which they can be modified.
  • The actions that can be carried out on each component of the project can be accessed from a context menu.
    • Right-click a version to create a minor/major revision.

 

Properties pane

        Publication - Properties Pane.png

PropertiesPaneDescription

It displays the contextual properties of the component selected in the Explorer pane: project, procedure, folder, resource, etc.

Toolbar

  • Select language drop down.png: Select the display language for the Properties pane components.
  • Properties browsing history icons.png : Navigate in the history of the properties viewed during the current session. Note: The history is reset for each Product name - ev Self Help.png session.
  • Additional icons are displayed based on the component type selected.

             Open url.png see Toolbar for:

List of tabs

Properties: Set of properties of the component. 

Go to the tab: View > Properties

  • The name of the component is shown at the top of the pane.
  • The sub-tabs are contextual to the component type.

             Open url.png See Properties for:

 

Procedure: How to create a new version of a project

See the detailled step by step in ev Self Help

Step 1: Create a new minor/major version

1. Go to the graphic editor.

2. Expand the project tree using Tree expand icon.png in the Explorer pane.

3. Right-click an active version of the project, identified by Property OK icon.png, and select Create a new major/minor revision from the context menu.
The Edit new version action dialog box is opened.
 

Step 2: Information on the version planning

  • Start creation immediately using the Execute now option; or
  • Defer creation using the Delay execution at:
    • Enter the start date and time.

The new version is shown in the Explorer pane.

Tags:
Last modified by Unknown User on 2018/12/14 12:14
Created by Administrator XWiki on 2018/12/14 11:21

Shortcuts

Recent Updates

Haven't been here in a while? Here's what changed recently:

-   Product name - ev itsm.png
-   Product name - ev sas.png

Interesting Content

How to Automate Integration
Add a Shortcut to an App
History
Quick Dashboard
Full text search - Stop Words

Powered by XWiki ©, EasyVista 2019