Self Help - Project


A project defines a workspace that is linked to a domain. It contains a set of business processes that are defined as procedures.

  • Projects are managed from the Explorer pane of the graphic editor.
  • Project components are grouped together in folders according to their nature (resources, procedures, forms, variables, etc.)  - Open url.png see Content of a project
  • The procedures are provided to users by publishing versions according to their access rights.
  • Multilingual management is proposed in all the components of the project: translation of resources, procedures, forms, etc.
  • Access rights for the project are defined for writers.

Notes

  • Each project is self-contained; there is no interaction between the projects.
    • A project may be used as a working library by the other projects.
    • A project can be used as a template to create a new project.
  • When a project is created, several folders are created automatically:
    • Library and Recycle bin
    • Macro libraries and predefined variables.
  • When a folder is moved, all the links that refer to that folder are automatically updated in the procedures.

Caution

  • If you delete a folder, all of its contents will be deleted.

Best Practice big icon.pngBest practice

Contents of a project

  • Information icons before the component name:
Icon Object Description
Project icon.png Project Product name - ev Self Help.png project made up of a set of components.
Folder icon.png Folders Directories that make managing the project components easier.
  • Each folder may contain subfolders.
  • Each subfolder may comprise any number of additional components and subfolders.
  • Each project contains 2 specific folders: Resources and Library.
Resources folder Library of common components that can be accessed by all the procedures of the project - Open url.png see Description of resources
  • Text icon.png HTML content
  • File icon.png Files: pictures, videos, PDF, etc.
  • Link icon.png Hyperlinks
  • Form icon.png Forms

Any modification made to a resource is automatically applied in all the procedures that use it.

Best Practice icon.png To make resource management easier, create one subfolder for each component type.

Example documentation icon EN.png Forms, Pictures subfolders

Library folder List of variables and formulae used by all the procedures of the project.
  • Any modification made to a variable or a function is automatically applied in all the procedures that use it.
  • Variable types:
    • associated with the fields created in forms;
    • created manually;
    • generic (found by default in each project) - Open url.png see List.
  • Formula types:
    • created manually (standard and conditional);
    • generic (found by default in each project).
Procedure icon.png Procedures List of business processes of the project - Open url.png see Description of a procedure
  • Double-click a procedure to display its graphic representation in the Design zone of the graphic editor.
  • User procedure access icon.png displayed next to the procedure name indicates that its access is authorized to users: right-click the name and select Allow user access from the context menu.
Recycled bin icon.png Recycle bin List of procedures, variables and forms deleted from the project but that can be recovered provided that the folder has not been emptied.

Properties of a project

         Project Properties tabs.png

Access: select the project in the Explorer pane of the graphic editor, then go to menu View > Properties

Toolbar

  • Select language drop down.png: Select the display language for the project properties content.
  • Properties browsing history icons.png : Navigate in the history of the properties viewed during the current session. Note: The history is reset a new Product name - ev Self Help.png session is started.
  • Parent folder icon.png : Parent folder is selected automatically in the tree.

List of tabs

Info.

Information about the project (version, creation date, last update date). 

  • Locks: Number of writers who are currently using the project.
  • Indexed

Writers

List of writers authorized to work on the project, shown with their access rights (read-only/ write/ publish). Open url.png See the procedure.
         Properties - Writers tab.png

Note: The icons will be grayed based on your access rights. Open url.png See States of the access rights management icons.

  • Add writer icon.png  in the toolbar: Add a new writer to the project and define his or her access rights.
  • Access rights management icons:
    • Update writer icon.png  next to a writer: Update his or her access rights to the project.
    • Delete writer icon.png  next a writer: Delete his or her access rights. He or she will automatically disappear from the list.
       
  • Information icons and color codes based on the writer’s access rights:
Icon Color User type Rights
Rights - Domain manager icon.png Legend - Red color.png Domain administrator For all the projects in his or her domain:
  • is the owner;
  • has full read, write and publishing rights;
  • can add users;
  • can assign user rights;
  • can delete users.
Rights - Owner project icon.png Legend - Orange color.png Project owner For his or her project:
  • has full read, write and publishing rights;
  • can add users;
  • can assign user rights, except for domain administrator rights;
  • can delete users, except for the domain administrator.
Rights - Guest - All rights icon.png Legend - Blue color.png Guest (Read/Write/Publish) For the project:
  • has full read, write and publishing rights;
  • can add users;
  • can assign user rights, except for domain administrator rights;
  • cannot delete users.
Rights - Guest - Write and read icon.png Legend - Cyan color.png Guest (Read/Write) For the project:
  • has only read and write rights;
  • can add users;
  • can assign user rights, except for domain administrator rights;
  • cannot delete users.
Rights - Guest - Read only icon.png Legend - Green color.png Guest (Read Only) For the project:
  • has read-only rights;
  • cannot add users;
  • cannot assign user rights;
  • cannot delete users.

Quota

View the space:

  • used by the project version;
  • used by the other projects;
  • available on the server (Note: Unless the space is unlimited for the server).

Statistics

Statistics of the use of each procedure of the project (number of executions launched and their average duration, average number of steps in the procedure)  - Open url.png see Procedure

Definition of metadata

List of data of the project (procedure names, step titles, form field labels, description, etc.).

  • All of the metadata may contain hidden text which is placed within [ ] characters.

Metadata deactivated

Managing access rights

Access rights are defined for each project.

  • The domain administrator:
    • Is automatically the owner of all the projects.
    • Has full rights to all the projects.
  • The owner of a project:
    • Has full rights to his or her project.
    • Several users may be defined as the owners of a project.
  • Only the administrator or one of the owners of a project can assign access rights to writers in this project.
    • A user can modify his or her own rights.
    • If a user restricts his or her rights, a message is displayed. Subsequently, only the domain administrator or one of the owners can restore the user’s rights.

Open url.png See:

Managing versions

A project version contains a selection of procedures that can be executed by user groups. A publishing process is used to place them at their disposal.

  • There are two types of versions:
    • major version: identifies a scheduled version;
    • minor version: anomaly and bug correction.
  • The publishing may be immediate or deferred - Open url.png see Procedure

    Caution: Until a version has been published, only the project owner or a domain administrator can modify the project and its procedures.

  • Each published version:
    • replaces the previous version and is automatically incremented by a unit;
    • can be activated/deactivated individually using the publishing manager;
    • can no longer be modified in the graphic editor.

Multilingual management

  • Each project can be translated into several languages  - Open url.png see Procedure
  • The languages proposed for translating a project can be accessed via the menu Help > Preferences > Allowed languages.
  • The content of the components may be translated:
    • component by component, using the Design pane of the graphical editor;
    • by exporting the components to translation files and then reimporting them - Open url.png see Procedure

      Best Practice icon.png  Lock the project until all the exported files are reimported (Prevent updates before translation return check box).

Procedures

How to create a project

See the detailled step by step in ev Self Help

Step 1: Create a new project

1. Go to the graphic editor  - Open url.png see Procedure

2. Click File > New > Project in the menu bar.

3. Select the creation method of your new project:

  • Method 1: Create an empty project:
    • click the Create a new empty project option;
    • enter the name of the new project;
    • click Finish.
      The new project is shown in the Explorer pane.
  • Method 2: Use a template:
    • click the Create from a published version option;
    • select the desired project version;
    • click Finish.
      The new project is shown in the Explorer pane and named Copy of ....
       

Step 2: Create the folders of the project

1. Right-click the project label.

2. Select New from the context menu, and then Folder.

3. Name the folder.

4. Repeat these actions for all the folders to be added to the project, starting from the location of the new folder each time.

Move a folder

  • Drag&drop it to its new location.
     

Delete a folder

  • Right-click the step and select Delete from the context menu. Keyboard shortcut icon.png <Del>
     

Step 3: Create the resources of the project

1. Right-click the project folder in which you want to create the new resource.

2. Select New from the context menu, and the type of resource to create.
         Insert new resource.png

3. Define the content of the resource according to its type.
        Open url.png see Procedure How to create a resource (step 3)

The resource is inserted in the Explorer pane.

4. Add all the resources of the project in the same way.
  

Step 4: Create the Product name - ev Self Help.png procedures of the project

1. Right-click the project folder in which the new procedure must be created and select New > Procedure from the context menu.

2. Create the steps in the Design pane.

    Open url.png see Complete procedure How to create a procedure Product name - ev Self Help.png

    Open url.png see Procedure for each step type:

  • Action
  • Action with switch
  • Branch
  • Page
  • Page with choices
  • Marker
  • Sub-procedure

3. Add all the procedures of the project in the same way.
 

Step 5: Test the Product name - ev Self Help.png procedures of the project

    Open url.png see Procedure 
 

Step 6: Define the writers’ access rights to the project

    Open url.png see Manage access rights

    Open url.png see Procedure

How to manage access rights to a project

See the detailled step by step in ev Self Help

Step 1: Display the writers

1. (Optional) Display the Properties pane using the menu View > Properties.

2. Click the Writers subtab of the Properties pane.

Step 2: Manage authorized writers


States of the access rights management icons

Action Active icon Inactive icon
Add a writer to the project Add writer icon.png
  • You are the Domain administrator.

    or

  • You are one of the project owners.

    or

  • You have Read / Write / Publish or Read / Write rights to the project.
Add writer icon - Grayed.png
  • You only have Read Only rights to the project.
Modify access rights to the project for a user Update writer icon.png
  • You are the Domain administrator.

    or

  • You are one of the project owners and the user you want to modify is not the Domain administrator.

    or

  • You have Read / Write / Publish or Read / Write rights to the project and the user you want to modify is not the Domain administrator.
Update writer icon - Grayed.png
  • You want to modify the rights of the Domain administrator.

    or

  • You only have Read Only rights to the project.
Delete access rights to the project for a user Delete writer icon.png
  • You are the Domain administrator.

    or

  • You are one of the project owners and the user you want to delete is not the Domain administrator.
Delete writer icon - Grayed.png
  • You are one of the project owners and you want to delete the rights of the Domain administrator.

    or

  • You only have Read Only or Read / Write or Read / Write / Publish rights to the project.

Add access rights for a writer

  • Click Add writer icon.png.
    The list of all the users who have access to the server is displayed.
             Add writer.png
  • Select the desired user.
  • Assign the rights by choosing from the four options given in Access rights. Open url.png See the description.
  • Click Finish.
  • Repeat these actions to add the other writers.
     

Modify the access rights of a writer

  • Click Update writer icon.png to select the desired writer.
             Update writer.png
  • Assign the rights from among the four options given.
    The signage for the writer is updated.
     

Delete a project writer

  • Click Delete writer icon.png to select the desired writer.

How to publish a project

See the detailled step by step in ev Self Help

Step 1: Select the project to publish

1. Right-click the project in the Explorer pane and select Publish... from the context menu.

2. (Optional - If linked resources are opened) Click Yes if the There are opened editors associated with this project. message is displayed.
 

Step 2: Select the user groups that are allowed to run the procedures in the project

1. Click each authorized group in the Existing groups list to the left.

2. Click Arrow right.png.

3. Click Next.
 

Step 3: Choose executable procedures

1. Select each authorized procedure.

2. Click Next.
 

Step 4: Version history information

1. Enter the description of the version.

2. Select the KEEP the next version of the project in the workspace check box if the version to publish is the final version. 

3. Select the activation/deactivation mode of the new version and the former versions among the three options given:

  • PUBLISH and REPLACE: enables the new version and disables the former versions.
  • PUBLISH and ACTIVATE: enables the new version without disabling the former versions.
  • PUBLISH and NOT ACTIVATE: disables the new version without disabling the former versions.

4. Select the Automatically switch to the publishing perspective when finished checkbox to open the publishing manager automatically at the end of the process.

5. Click Finish.
 

Step 5: Publishing scheduling information

Caution: Until a project has been published, only the project owner or a domain administrator can modify it.

  • Schedule immediately by selecting the Publish now option; or
  • Defer publishing using the Publish at option:
    • Enter the start date and time;
    • Select the Prevent project modifications before publication checkbox.
       

Step 6 (optional): Send an e-mail to inform users after the publishing

1. Select the Send and e-mail checkbox.

2. Enter the message subject and body.
 

Step 7: Start the publishing

  • Click Finish.
    • The scheduled publishing is started immediately or at the specified start time. 
    • A new working version is created in the Explorer pane of the graphic editor.
    • The published version is created in the publishing manager.
    • The publishing manager is opened automatically if you selected that option in step 4.

How to translate a project

    Open url.png see Multilingual management

Translate component by component

See the detailled step by step in ev Self Help

Step 1: Select the translation languages

1. Click Help > Preferences.

2. Click Allowed languages.

3. Select the languages you wish to use for your multilingual management of projects.

4. Click Apply and then OK.
 

Step 2: Translate the title of the project and its components

1. Select the translation language using Select language drop down.png in the toolbar of the Explorer pane.

2. Translate the title of the project.

  • Right-click the title.
  • Select Rename... from the context menu. Keyboard shortcut icon.png <F2>
  • Enter the label in the selected language.
  • Press <Enter> to save.
    The translated label is saved. The label in the reference language is shown within brackets and is grayed.

3. Repeat the same actions to translate the name of all the project components.
 

Step 3: Translate procedure objects

1. Select the translation language using Select language drop down.png in the toolbar of the Design pane.

2. Translate all the titles of objects show in the diagram.

  • Right-click each object.
  • Select Rename... from the context menu. Keyboard shortcut icon.png <F2>
  • Enter the label in the selected language.
  • Press <Enter> to save.
    The translated label is saved.
     

Step 4: Translate the content of procedure objects

    Open url.png  also see Translate by exporting/importing the project

1. Open the Description pane in the translation language using the menu View > Description....
A new Description view preceded by a flag in the translation language is displayed.
         Multilingual description pane.png

2. In the diagram on the Design pane, click the procedure object whose content is to be translated.
The content of the object is displayed in the Description pane in the translation language.

3. Translate the content of the object in the Content tab of the Description pane.

4. Repeat these actions for all procedure objects that have content that needs to be translated.
 

Step 5: Translate the resources of a project
    Open url.png see Description of the resource types 

File resources

1. Add the translated file to the Explorer pane.

  • Add it to the folder that contains the original file.
  • Give it another name.
             Example documentation icon EN.png  Original EN file: Platform Pricing; New FR file: Prix par plateforme

2. Replace the original file with the new file in the translated procedure.

  • Click the original file in the Explorer pane.
  • Click the Used by tab in the Properties pane.
  • Click the first step where the file is used.
    • Case 1: The file is added as an attachment to the step
      • Select the translation language using Select language drop down.png in the toolbar of the Design pane.
      • Drag&drop the translated file to the step in the Design pane.
    • Case 2: The file is inserted in the step content editor
      • Select the Description view that is preceded by the translation language icon in the Description pane.
      • Drag&drop the translated file to the Content tab.
  • Repeat these actions for each of the steps in which the original file is used.
     

HTML content resources

1. Double-click the resource in the Explorer pane.

2. Select the translation language using Select language drop down.png in the toolbar of the Design pane.

3. Translate in the Design pane.

Form resources

1. Double-click the resource in the Explorer pane.

2. Select the translation language using Select language drop down.png in the toolbar of the Design pane.

3. Translate the title of the form components.

4. Double-click the first component.
The content of the object is displayed in the Description pane in the translation language.

5. Click the Input/Output tab, and then Modify the List.

6. Translate the labels of each itel of the component and click Finish.

Translate by exporting/importing the project

See the detailled step by step in ev Self Help

Step 1: Export the object content to an archive

1. Right-click the object and select Translate > Export translation files from the context menu.

2. Select the content to export in the tree.

3. Select the Prevent updates before translation return checkbox to lock the project until all the exported files have been reimported.

4. Select the translation language in Select language drop down.png.

5. Enter the name and location of the translation archive.

6. Click Finish.

  • A .zip file is created at the selected location.
  • If you have locked the object, it cannot be modified until it is reimported.
    • Its name is shown in red in the Explorer pane.
    • The wording Translation export lock is shown after its name.
     

Step 2: Translate file contents

1. Unzip the translation archive.
.xlf files are extracted (files in XML format).

2. Open the first .xlf file.

3. Translate the content of the object.

4. Save the file in .aar format.

5. Repeat these actions to translate and save the other files.
 

Step 3: Reimport the translation archive

1. Right-click the object and select Translate > Import a translation archive from the context menu.
The lock is removed for each reimported object.
 

Unlock an object manually

  • Right-click the object and select Remove lock from the context menu.

How to get the use statistics a project

See the detailled step by step in ev Self Help

Step 1: Select criteria

1. Enter your selection criteria (period, include working version).

2. Click Show Statistics.
 

Step 2 (optional): Save the results to a file

All results

1. Click Export All.
 

Select procedures

1. Select the procedures in the table.

2. Click Export Selection.
 

Step 3 (optional): Get statistics on procedure execution

1. Get the user’s procedure identifier from the user.

2. Enter this identifier.

3. Click Open a Procedure Execution.

Tags:
Last modified by Unknown User on 2019/05/15 16:41
Created by Administrator XWiki on 2018/12/14 11:20
Powered by XWiki ©, EasyVista 2019