La gestion multilingue d'un projet Self Help


L'ensemble des composants de chaque projet Self Help peut être traduit en plusieurs langues : libellés des dossiers, titres des procédures, contenu des étapes, champs des formulaires, ...

  • La traduction peut s'effectuer composant par composant ou via l'export / import d'une archive du projet Self Help.
  • Un outil de traduction automatique est disponible pour les étapes de procédures et les ressources de type Contenu Html. La langue d'origine est automatiquement détectée et peut être traduite en 65 langues différentes. La traduction peut ensuite être ajustée manuellement.

Remarques

  • Les langues proposées pour la traduction d'un projet Self Help sont disponibles via le menu Aide > Préférences > Langues autorisées.
  • Lors d'une traduction via l'export / import d'une archive, le projet Self Help est automatiquement verrouillé tant que l'ensemble des fichiers exportés ne sont pas réimportés.

Attention

  • Si vous déverrouillez un projet Self Help en cours de traduction, le  contenu traduit ne reflètera pas vos modifications.

Procédures

Comment traduire un projet Self Help composant par composant

Voir le pas à pas détaillé dans Self Help

Étape 1 : Sélection des langues de traduction

1. Cliquez sur le menu Aide > Préférences.

2. Cliquez sur Langues autorisées.

3. Cochez les langues que vous souhaitez utiliser pour votre gestion multilingue des projets Self Help.

4. Cliquez sur Appliquer puis OK.
 

Étape 2 : Traduction du titre du projet Self Help et de ses composants

1. Sélectionnez la langue de traduction via Select language drop down.png dans la barre d'outils du volet Explorateur.

2. Traduisez le titre du projet Self Help.

  • Cliquez droit sur le titre.
  • Sélectionnez Renommer... dans le menu contextuel. Keyboard shortcut icon.png <F2>
  • Saisissez le libellé dans la langue sélectionnée.
  • Enregistrez via la touche <Entrée>.
    Le libellé traduit est enregistré. Le libellé de la langue de référence est affiché entre parenthèses et en gris.

3. Réalisez les mêmes actions pour traduire le nom de tous les composants du projet Self Help.
 

Étape 3 : Traduction des objets de la procédure

1. Sélectionnez la langue de traduction via Select language drop down.png dans la barre d'outils du volet Conception.

2. Traduisez l'ensemble des titres des objets placés sur le diagramme.

  • Cliquez droit sur chaque objet.
  • Sélectionnez Renommer... dans le menu contextuel. Keyboard shortcut icon.png <F2>
  • Saisissez le libellé dans la langue sélectionnée.
  • Enregistrez via la touche <Entrée>.
    Le libellé traduit est enregistré.
     

Étape 4 : Traduction du contenu des objets de la procédure

   Open url.png  voir également :

1. Affichez le volet Description dans la langue de traduction via le menu Vue > Description....
Une nouvelle vue Description précédée du drapeau de la langue de traduction est affichée.
         Multilingual description pane.png

2. Cliquez dans le diagramme du volet Conception sur l'objet de la procédure dont le contenu est à traduire.
Le contenu de l'objet est affiché dans le volet Description de la langue de traduction.

3. Traduisez le contenu de l'objet dans l'onglet Contenu du volet Description.

4. Répétez ces actions pour l'ensemble des objets de la procédure ayant un contenu à traduire.
 

Étape 5 : Traduction des ressources du projet
    Open url.png voir Description des types de ressources

Ressources de type Fichier

1. Ajoutez le fichier traduit dans le volet Explorateur.

  • Ajoutez-le dans le même dossier que le fichier original.
  • Donnez-lui un autre nom.

exemple  Fichier original EN : Platform Pricing ; Nouveau fichier FR : Prix par plateforme

2. Remplacez le fichier original avec ce nouveau fichier dans la procédure traduite.

  • Cliquez sur le fichier original dans le volet Explorateur.
  • Cliquez sur l'onglet Utilisée par dans le volet Propriétés.
  • Cliquez sur la première étape où le fichier est utilisé.
    • 1er cas : Le fichier est attaché comme pièce-jointe à l'étape
      • Sélectionnez la langue de traduction via Select language drop down.png dans la barre d'outils du volet Conception.
      • Cliquez-glissez le fichier traduit vers l'étape dans le volet Conception.
    • 2ème cas : Le fichier est inséré dans l'éditeur de contenu de l'étape
      • Sélectionnez la vue Description précédée de l'icône du drapeau de la langue de traduction dans le volet Description.
      • Cliquez-glissez le fichier traduit vers l'onglet Contenu.
  • Répétez ces actions pour chacune des étapes où le fichier original est utilisé.
     

Ressources de type Contenu Html

1. Double-cliquez sur la ressource dans le volet Explorateur.

2. Sélectionnez la langue de traduction via Select language drop down.png dans la barre d'outils du volet Conception.

3. Effectuez la traduction dans le volet Conception.

Ressources de type Formulaire

1. Double-cliquez sur la ressource dans le volet Explorateur.

2. Sélectionnez la langue de traduction via Select language drop down.png dans la barre d'outils du volet Conception.

3. Traduisez le titre des composants du formulaire.

4. Double-cliquez sur le premier composant.
Le contenu de l'objet est affiché dans le volet Description de la langue de traduction.

5. Cliquez sur l'onglet Entrées/Sorties puis sur Modifier la liste.

6. Traduisez les libellés de chaque élément du composant et cliquez sur Terminer.

Comment traduire un projet Self Help par export / import d'une archive

Voir le pas à pas détaillé dans Self Help

Étape 1 : Exportation du contenu des objets dans une archive

1. Cliquez droit sur l'objet et sélectionnez Traduction > Exporter les fichiers de traduction dans le menu contextuel.

2. Sélectionnez le contenu à exporter dans l'arborescence.

3. Cochez la case Empêcher les modifications avant l'import de traduction pour verrouiller le projet Self Help tant que l'ensemble des fichiers exportés ne sont pas réimportés.

4. Sélectionnez la langue de traduction via Select language drop down.png.

5. Indiquez le nom et l'emplacement de l'archive de traduction.

6. Cliquez sur Terminer.

  • Un fichier .zip est créé à l'emplacement sélectionné.
  • Si vous avez verrouillé l'objet, celui-ci ne peut plus être modifié tant qu'il n'est pas réimporté.
    • Son nom est affiché en rouge dans le volet Explorateur.
    • La mention Verrou de traduction est affichée après son nom.
     

Étape 2 : Traduction du contenu des fichiers

1. Dézippez l'archive de traduction.
Des fichiers .xlf sont extraits (fichiers au format XML).

2. Ouvrez le premier fichier .xlf.

3. Effectuez la traduction du contenu de l'objet.

4. Sauvegardez le fichier.

5. Réalisez les mêmes actions pour traduire et sauvegarder chaque fichier.
 

Étape 3 : Réimportation de l'archive de traduction

1. Effectuez un zip de l'archive de traduction avec tous les fichiers modifiés.

2. Cliquez droit sur l'objet et sélectionnez Traduction > Importer une archive de traduction.

3. Sélectionnez le fichier zippé.

  • Le contenu de l'ensemble des fichiers de l'archive est réimporté.
  • Le verrou est supprimé sur chaque objet réimporté.

Déverrouillage manuel d'un objet

  • Cliquez droit sur l'objet et sélectionnez Supprimer le verrou dans le menu contextuel.

Comment utiliser l'outil de traduction automatique

Étape 1 : Rédaction du contenu d'un objet dans la langue d'origine

1. Cliquez sur l'objet à traduire sur la représentation graphique du volet Conception.
L'onglet Contenu est ouvert dans le volet Description.

2. Cliquez sur la langue d'origine dans la barre d'onglets des traductions.

3. Rédigez le contenu dans la langue d'origine.
         Translate procedure - Source content.png

Étape 2 : Traduction du contenu de l'objet dans la langue cible

1. Cliquez sur la langue cible dans la barre d'onglets des traductions.
Le texte de la langue d'origine est automatiquement inséré.
         Translate procedure - Destination content.png

2. Cliquez sur le menu Affichage puis sur l'icône Translate icon.png.
La langue d'origine est automatiquement détectée.

3. Sélectionnez la langue cible.

4. Cliquez sur Traduire.
Le texte de la procédure est automatiquement traduit dans la langue cible.

5. Effectuez les ajustements nécessaires sur la traduction automatique du texte.

Tags:
Modifié par Utilisateur inconnu le 2020/06/08 17:36
Créé par Administrator XWiki le 2020/01/18 13:41

Raccourcis

L'actualité mensuelle
•  Newsletter

Tous les changements
•  Service Manager
•  Service Apps
•  Self Help

Glossaire

Powered by XWiki ©, EasyVista 2020