The Multilingual Management of a Self Help Project


For multilingual Self Help project, all components can be translated into different languages, e.g. folder labels, procedure titles, step content, form fields, etc.

You can use a combination of methods to do this. Open url.png See the description.

  • Perform the translation component by component.
  • Perform the translation by exporting and importing a translation archive for the Self Help project.
  • Use an automatic translation tool for procedure steps and HTML content resources.

Notes

  • You define the languages for the Self Help project  in the Desktop Studio in edit mode by selecting Help > Preferences > Allowed Languages in the menu.

Caracteristics of each translation method

Translation component by component

  • Translation is performed for each language.
  • This means that you have to access each component and translate them individually, i.e. elements in the tree structure, procedure step names, text in steps, resource content, etc.

Translation by exporting and importing a translation archive

  • A translation archive is created for a given language and for selected components.
  • Translation is done directly in the exported XLIFF files.
  • Once translation is done, you reimport the archive to the Self Help project.
     

    Notes:

  • XLIFF files contain numerous tags in XML format. We therefore recommend that you ask a translation agency to perform the translation using industry-specific software. Industry-specific software use translation memories that store and reuse segments of sentences subsequently. This means that only translatable data you have added or modified from one version to the next will be processed.
  • We therefore recommend thay you lock the Self Help project as long as the translation archive has not been reimported. If any modification is made to the content in the meantime, the exported file will no longer be valid.

Automatic translation tool

  • Translation is performed for each language in the Conception pane in edit mode.
  • The text in the source language will automatically be translated into the target language.
  • If required, you can make modifications manually to the translation for each of the languages.

Procedures

How to translate a Self Help project, component by component

See the detailed step-by-step procedure in Self Help.

Step 1: Select the translation languages.

1. Select Help > Preferences in the menu.

2. Click Allowed Languages.

3. Select the languages for the multilingual management of your Self Help projects.

4. Click Apply and click OK.
 

Step 2: Translate the Self Help project name and its components.

1. Click Select language drop down.png in the toolbar of the Explorer pane to select the translation language.

2. Translate the name of the Self Help project.

  • Right-click the name.
  • Select Rename from the contextual menu. Keyboard shortcut icon.png <F2>
  • Enter the name in the selected translation language.
  • Press <Enter> to save.
    The translated name is saved. The name in the source language is displayed in gray between brackets.

3. Repeat these actions to translate the names of all components in the Self Help project.
 

Step 3: Translate procedure objects.

1. Click Select language drop down.png in the toolbar of the Conception pane to select the translation language.

2. Translate all object names in the flow chart.

  • Right-click each object.
  • Select Rename from the contextual menu. Keyboard shortcut icon.png <F2>
  • Enter the name in the selected translation language.
  • Press <Enter> to save.
    The translated name is saved.
     

Step 4: Translate the content of procedure objects.

   Open url.png Also see:

 

1. Display the Description tab of the translation language by selecting View > Description in the menu.
A new Description tab preceded by the translation language flag will appear.
         Multilingual description pane.png

2. Click the procedure object whose content you want to translate in the flow chart of the Conception pane.
The content of the object will appear in the Description tab of the translation language.

3. Translate the content of the object in the Content tab of the Description pane.

4. Repeat these actions for all procedure objects containing content to be translated.
 

Step 5: Translate project resources.
    Open url.png See the description of different types of resources.

Document resources

1. Add the translated document to the Explorer pane.

  • Add it to the same folder as the source document.
  • Modify its name.

example  Source - EN document: Platform Pricing; Target - FR document: Prix par plateforme

2. Replace the source document with the new one in the translated procedure.

  • Click the source document in the Explorer pane.
  • Select the Used by tab in the Properties view.
  • Click the first step where the document is used.
    • Case 1: The document is added as an attachment in the step.
      • Click Select language drop down.png in the toolbar of the Conception pane to select the translation language.
      • Click and drag the translated document to the step in the Conception pane.
    • Case 2: The document is inserted in the content editor of the step.
      • Select the Description tab of the translation language you want in the Description pane.
      • Click and drag the translated document to the Content tab.
  • Repeat these actions for each step where the source document is used.
     

HTML content resources

1. Double-click the resource in the Explorer pane.

2. Click Select language drop down.png in the toolbar of the Conception pane to select the translation language.

3. Perform the translation in the Conception pane.

Form resources

1. Double-click the resource in the Explorer pane.

2. Click Select language drop down.png in the toolbar of the Conception pane to select the translation language.

3. Translate the component names in the form.

4. Double-click the first component.
The content of the object will appear in the Description tab of the translation language.

5. Select the Input/Output tab and click Update list.

6. Translate the name of each component and click Finish.

How to translate a Self Help project by exporting and importing an archive

See the detailed step-by-step procedure in Self Help.

Step 1: Export the content of objects to an archive.

1. Right-click the object and select Translation > Export text files for localization from the contextual menu.

2. Select the content to be exported in the tree structure.

3. Tick the option called Prevent updates before translation return to lock the Self Help project as long as all of the exported files have not been reimported.

4. Click Select language drop down.png to select the translation language.

5. Specify the name and location of the translation archive.

6. Click Finish.

  • A ZIP folder will be created at the selected location.
  • If you locked the object, it cannot be modified as long as it has not been reimported.
  • Its name will appear in red in the Explorer pane.
  • The words Translation export lock will be displayed after its name.

 

Step 2: Translate the content of files.

Caution: XLIFF files contain numerous tags in XML format. We therefore recommend that you ask a translation agency to perform the translation using industry-specific software.

1. Unzip the translation archive.
XLF files will be extracted (XML format).

2. Open the first XLF file.

3. Translate the content of the object.

4. Save the file.

5. Repeat these actions to translate and save each file.
 

Step 3: Reimport the translation archive.

1. Save the translation archive as a ZIP folder with all of the modified files.

2. Right-click the object and select Translation > Import translated archive files from the contextual menu.

3. Select the ZIP folder.

  • The content of all files in the archive will be reimported.
  • The lock will be removed for each reimported object.

Unlock an object manually

  • Right-click the object and select Remove lock from the contextual menu.

How to use the automatic translation tool

Step 1: Write the content of the object in the source language.

1. Click the object you want to translate in the flow chart of the Conception pane.
The Content tab will appear in the Description pane.

2. Click the source language in the translation tab bar.

3. Write the content in the source language.
         Translate procedure - Source content.png

Step 2: Translate the content of the object into the target language.

1. Click the target language in the translation tab bar.
The text in the source language will automatically be inserted.
         Translate procedure - Destination content.png

2. Select View in the menu and click the Translate icon.png icon.
The source language will automatically be detected.

3. Select the target language.

4. Click Translate.
 The text of the procedure will automatically be translated into the target language.

5. If required, you can make modifications manually to the automatic translation.

Tags:
Last modified by Unknown User on 2020/12/07 11:30
Created by Administrator XWiki on 2020/01/18 13:41

Shortcuts

Recent changes
•  EV Service Manager
•  Service Apps
•  EV Self Help
•  Service Bots

Powered by XWiki ©, EasyVista 2021