Les procédures d'un projet Self Help


Les procédures d'un projet Self Help décrivent des processus métier sous forme d'arbres décisionnels.
        Procedure - Presentation.png

  • Les procédures sont :
    • gérées et bâties depuis le mode Édition du studio ;
    • pilotées par un workflow de validation pour gérer l'avancement de leur contenu jusqu'à la publication du projet Self Help ;
    • mises à disposition des utilisateurs via un processus de publication de version  - Open url.png voir Gestion des versions
  • Chaque arbre décisionnel se présente sous la forme d'une suite d'étapes de 2 natures  - Open url.png voir Description :
    • étapes interactives : visibles sous forme de pages web par l'utilisateur exécutant la procédure, elles sont utilisées pour demander des renseignements via des formulaires, faire un choix entre plusieurs réponses, afficher des informations (texte, tableaux, images, ...), faire des liens vers des sites internet, ... ;
    • étapes automatiques : transparentes pour l'utilisateur, elles sont utilisées pour exécuter des scripts, communiquer avec des services tiers via des web services, réaliser des tests ou des calculs, ...
  • Chaque étape de procédure peut :
    • renvoyer un résultat (réponse de l'utilisateur, valeur d'un calcul, résultat d'un test, ...) qui permet d'orienter le parcours de l'utilisateur dans le processus : passage à l'étape suivante, sélection d'une branche, saut vers une autre étape via une boucle, fin de la procédure, ...
    • peut utiliser / afficher des ressources : fichiers (images, vidéos, PDF, ...), contenu Html, formulaires, ...
  • Un rapport d'exécution est généré pour chaque procédure, qui retrace l'ensemble des étapes et des branches parcourues par l'utilisateur.

Remarques

  • Droits d'accès aux procédures :
    • Plusieurs rédacteurs peuvent avoir accès en modification sur une même procédure. Lorsqu'un rédacteur travaille sur la procédure, les autres rédacteurs ont uniquement un accès en lecture seule.
    • Pour pouvoir visualiser une procédure dans le navigateur internet, elle doit être définie comme point d'entrée pour les utilisateurs  - Open url.png voir Procédure
    • Un utilisateur accède à la procédure via une URL, suivant ses droits d'accès. L'accès aux sous-procédures via une URL n'est pas possible. 
  • Une procédure est toujours délimitée par :
    • une étape Début Step type icon - Start.png qui est unique ;
    • une étape Fin Step type icon - End.png qui termine chaque branche de la procédure.
  • Des sous-procédures peuvent être créées : elles permettent la création de sous-processus métier.
    • Toutes les procédures du projet Self Help peuvent être déclarées comme des sous-procédures.
  • Les objets utilisés à l'intérieur d'une procédure peuvent être :
    • propres à l'étape : ils sont gérés sous forme de pièces jointes rattachées à l'étape via le volet Conception ou le volet Description ;
    • partagés avec d'autres étapes ou avec d'autres procédures du projet Self Help : ils sont gérés sous forme de ressources communes accessibles via l'arborescence du volet Explorateur.
  • Les pages web affichant les étapes interactives utilisent le thème associé à la procédure. Seul un rédacteur ayant un profil Designer peut modifier son apparence.
  • Un texte peut être rendu invisible à l'utilisateur en le plaçant entre les caractères [ ].
             exemple  Hidden text.png
    • Toutes les métadonnées d'une procédure peuvent contenir du texte masqué : nom de la procédure, titre des étapes, libellés des champs de formulaire, description, ...
    • Le thème peut également gérer de façon automatique du texte masqué.
  • Rapport d'exécution d'une procédure :
    • Le rapport est généré par l'utilisateur, sur demande du rédacteur.
    • Tous les textes générés dans le rapport sont invisibles de l'utilisateur lorsqu'il exécute sa procédure.
    • Par défaut, le rapport contient le titre de l'ensemble des étapes et branches parcourues par l'utilisateur. Il peut être configuré étape par étape via le mode Édition du studio > volet Description > onglet Rapport.

Attention

  • Le dossier Corbeille d'un projet Self Help contient uniquement les ressources et procédures supprimées du projet. Il ne conserve pas de façon unitaire les étapes supprimées dans les procédures.

Bonnes pratiques

  • Utilisez les raccourcis clavier pour créer rapidement les composants des procédures.
  • Pour restaurer une procédure supprimée précédemment, cliquez sur le dossier Corbeille du projet Self Help dans l'arborescence du volet Explorateur.
  • Pour restaurer une étape ou son contenu, cliquez sur l'historique Editor - Undo toolbar.png des volets Conception et Description.
  • Créez une sous-procédure :
    • lorsque le sous-processus doit être réutilisé à plusieurs endroits du projet Self Help ;
    • lorsque la procédure contient plus de 5 étapes, afin de rendre le diagramme du volet Conception plus lisible.
  • Une ressource peut être insérée uniquement dans une procédure faisant partie du projet Self Help courant. Pour utiliser les ressources d'un autre projet Self Help, utilisez les fonctionnalités d'import / export  - Open url.png voir Procédure
  • La mise en page des ressources attachées en pièces jointes à une étape via le volet Conception est gérée automatiquement par le thème associé à la procédure. Pour effectuer votre propre mise en page, insérez la ressource dans l'éditeur de contenu de l'étape (volet Description > onglet Contenu)  - Open url.png voir Procédure
  • Pour afficher les procédures / sous-procédures utilisées par une procédure donnée, cliquez sur la procédure dans l'arborescence du volet Explorateur > vue Propriétés > onglet Utilisé par.
  • Utilisez le rapport d'exécution de la procédure pour rechercher la cause d'un blocage dans une étape.
  • Utilisez le texte masqué pour :
    • ajouter des mots clés dans la recherche sur le portail.

      Par défaut, seuls les mots du texte de la procédure peuvent être recherchés par l'utilisateur. Pour ajouter des mots clés non présents dans la procédure mais susceptibles d'être recherchés, allez sur la métadonnée Description de la procédure (volet Propriétés) et insérez-les sous forme de texte masqué.

      exemple  [Mettre à jour]Comment modifier une procédure
      ==> mot clé de recherche : Modifier
      ==> mot clé de recherche supplémentaire avec le texte masqué : Mettre à jour

    • modifier l'ordre de tri des procédures / dossiers dans le volet Explorateur.

      Par défaut, le classement est alphabétique. Pour définir votre propre classement, allez sur la métadonnée Description de chaque composant et ajoutez, sous forme de texte masqué, un numéro d'ordre devant le libellé.

      exemple  [0.2]Archivage, [0.1]Création
      ==> ordre alphabétique (par défaut) : Archivage, Création
      ==> ordre forcé par le texte masqué : Création, Archivage

Les propriétés d'une procédure

         Explorer Pane - Properties view - Procedure.png

Accès : mode Édition du studio > sélection de la procédure dans l'arborescence du volet Explorateur > vue Propriétés  - Open url.png voir Description 

ExplorerPane_ProcedurePropertiesView_Tabs

Liste des onglets

  • Info : Informations sur la procédure (date de création, date de dernière mise à jour, emplacement) et liste des métadonnées générales / spécifiques au type de procédure.
    • Double-cliquez sur une propriété pour saisir son contenu. Note : Les informations générales ne sont pas modifiables.
    • Les métadonnées peuvent être exportées  - Open url.png voir Comment exporter les métadonnées d'un projet Self Help
    • Pour renseigner les paramètres en entrée / sortie de la procédure, cliquez sur Paramètres > Éditer les paramètres.
    • Pour tester la procédure dans un navigateur internet, générez son URL via Lien > Cliquer pour générer un lien.
    • Pour associer une icône à la procédure, cliquez sur Icône > Add icon to procedure icon.png.
  • Utilise : Liste des ressources que la procédure utilise.
    • Cliquez sur <Ouvrir la procédure et afficher les étapes qui utilisent cette ressource> : le volet Conception affiche la procédure et la liste des ressources que la procédure utilise est affichée. Cliquez sur l'une des ressources pour la mettre en évidence sur le volet Conception.
  • Utilisé par : Liste des ressources qui utilisent la procédure.
    • Cliquez sur <Ouvrir la procédure et afficher les étapes qui utilisent cette ressource> : le volet Conception affiche la procédure et la liste des ressources utilisant la procédure est affichée. Cliquez sur l'une des ressources pour la mettre en évidence sur le volet Conception.
  • Statistiques : Statistiques d’utilisation de la procédure (nombre d’exécutions lancées et leur durée moyenne, nombre moyen d’étapes dans la procédure, ...)  - Open url.png voir Procédure
    • Cliquez sur Open procedure execution icon.png dans la barre d'outils pour ouvrir une exécution déterminée de la procédure.

Les types d'étapes

Type d'étape Visible de l'utilisateur Représentation graphique sur le volet Conception Description / Remarques
Step type icon - Start.png Début Not check icon.png Step type icon - Start.png
  • Étape indiquant le début de la procédure, sans interaction de l'utilisateur.
Step type icon - End.png Fin Not check icon.png Step type icon - End.png
  • Étape indiquant la fin de la procédure ou un arrêt, sans interaction de l'utilisateur.
  • Une étape Fin doit être renseignée pour chacune des branches de la procédure.

    Step End - Several branches.png

Step type icon - Action.png Action Not check icon.png Step Action.png
  • Étape automatique, sans interaction de l'utilisateur.

Open url.png voir procédure Comment créer une action

Step type icon - Action with conditions.png Action avec conditions Not check icon.png Step Action with conditions.png
  • Étape automatique, sans interaction de l'utilisateur, contenant une condition orientant vers plusieurs branches.
  • La condition est évaluée lorsque l'étape est exécutée.
  • La procédure enchaîne sur la branche répondant à la condition. Toutes les étapes définies sur cette branche sont exécutées, jusqu'à l'étape Fin Step type icon - End.png de la branche.

Open url.png voir procédure Comment créer une action avec conditions

Step type icon - Branche.png Branche Not check icon.png Step Branche.png
  • Étape liée à une condition d'exécution, définissant l'une des propositions d'une étape Action avec conditions ou d'une étape Page de choix.
  • Lorsque la condition est réalisée (condition de l'action vérifiée, choix de l'utilisateur), toutes les étapes définies sur la branche sont exécutées, jusqu'à l'étape Fin Step type icon - End.png de la branche.

    Step Branche - Continue till end.png

Open url.png voir procédure Comment créer une branche

Notes :

  • Survolez le titre avec la souris pour afficher la condition d'exécution de la branche.
  • Pour supprimer une étape comportant des branches, toutes les branches doivent être supprimées auparavant.
  • Un trait en pointillé - - - - indique la présence d'une condition de visibilité sur la branche : la branche est alors proposée uniquement si la condition est réalisée.

    Step Branche - with visibility condition.png

Step type icon - Page.png Page Check icon.png Step Page.png
  • Étape non interactive, présentant des informations à l'utilisateur via une page web.
  • La procédure enchaîne sur l'étape suivante sans aucun choix de l'utilisateur.

Open url.png voir procédure Comment créer une page

Step type icon - Choice page.png Page de choix Check icon.png Step Choice page.png
  • Étape interactive, présentant plusieurs propositions à l'utilisateur via une page web.
  • La procédure enchaîne sur la branche correspondant au choix de l'utilisateur. Toutes les étapes définies sur cette branche sont exécutées, jusqu'à l'étape Fin Step type icon - End.png de la branche.

Open url.png voir procédure Comment créer une page de choix

Step type icon - Resume point.png Point de reprise Not check icon.png Step Resume point.png
  • Étape automatique, sans interaction de l'utilisateur, permettant une redirection de la procédure.
  • La procédure enchaîne sur l'étape vers laquelle pointe le point de reprise.

Open url.png voir procédure Comment créer un point de reprise

Step type icon - Sub procedure.png Sous-procédure Check icon.png Step Sub procedure.png
  • Sous-processus métier constitué d'une série d'étapes (interactives / automatiques).
  • Une fois la sous-procédure exécutée, le processus reprend à l'étape suivante de la procédure principale.

Open url.png voir procédure Comment créer une sous-procédure

Le contenu d'une étape

Les étapes peuvent utiliser / afficher différents types d'objets.

Note : Pour afficher la liste des ressources qu'une procédure utilise : mode Édition du studio > sélection de la procédure dans l'arborescence du volet Explorateur > vue Propriétés > onglet Utilise
 

Objet Description / Remarques
Connecteurs
  • Connecteurs Excel, REST, SOAP, d'envoi de courrier, ...
  • Les types de connecteurs pouvant être créés sont gérés par EasyVista.
  • Pour insérer un connecteur dans une étape : volet Description > onglet Connecteurs > cliquez-glissez le document depuis l'arborescence du volet Explorateur
Contenu Html
  • Pour insérer un contenu Html dans une étape : volet Description > onglet Contenu > cliquez-glissez le document depuis l'arborescence du volet Explorateur
Documents
  • Fichiers de type .doc, .xls, .txt.
  • Pour insérer un document dans une étape : volet Description > onglet Fichiers liés > cliquez-glissez le document depuis l'arborescence du volet Explorateur
  • Les documents sont stockés sur le serveur et accessibles à tous les rédacteurs suivant leur droits.
Formulaires
  • Saisie interactive pour obtenir des informations de la part de l'utilisateur.
  • Pour insérer un formulaire dans une étape : volet Description > onglet Formulaires > cliquez-glissez le formulaire depuis l'arborescence du volet Explorateur
Formules
  • Les formules sont stockées dans une bibliothèque commune.

Note : Les formules ont une portée étendue à l'ensemble des procédures du projet Self Help

Images
  • Fichiers de type .bmp, .jpg, .png.
  • Pour afficher une image dans une étape : volet Description > onglet Contenu > menu Insertion > clic sur Image icon.png
  • Une image peut contenir des zones cliquables : régions actives exécutant une action après un clic (ouverture d'une page web, enchaînement sur l'étape suivante, orientation vers une branche de l'arbre, ...) - Open url.png voir Procédure
Liens hypertextes
  • Lien vers un site internet, une messagerie, ...
  • Pour insérer un lien hypertexte fixe dans une étape : volet Description > onglet Contenu > menu Insertion > clic sur Hyperlink icon.png
  • Pour définir un lien dynamique avec gestion de paramètres, créez une ressource de type Lien.
Macros
  • Pour afficher les macros d'une étape : volet Description > onglet Macros

Note : Les macros ont une portée limitée à l'étape qui les utilise.

Sous-procédures
  • Exécution d'un sous-processus métier.
  • Une fois la sous-procédure exécutée, le processus reprend à l'étape suivante de la procédure principale.
Tableaux
  • Utilisez des tableaux pour la présentation et l'organisation des informations sur la page web - Open url.png voir Procédure
  • Pour insérer un tableau dans une étape : volet Description > onglet Contenu > menu Insertion > clic sur Table icon.png
Texte
  • Utilisez la barre d'outils de l'éditeur de contenu pour formater le texte : volet Description > onglet Contenu > menu Accueil.
Variables
  • Les variables peuvent être :
    • globales : leur portée s'étend à l'ensemble des procédures du projet Self Help ;
    • locales : leur portée est limitée à la procédure active.

Note : Une liste de variables prédéfinies est fournie par EasyVista.

Vidéos
  • Fichiers de type flash (formats .swf et .flv) et html5 (formats .ogv, .mp4, .webm).
  • Pour afficher une vidéo dans une étape : volet Description > onglet Contenu > menu Insertion > clic sur Video icon.png
  • Des restrictions peuvent être définies suivant les navigateurs.

Procédures

Comment créer une procédure Self Help

Voir le pas à pas détaillé dans Self Help

Étape 1 : Sélection du projet Self Help

1. Sélectionnez le projet Self Help dans l'arborescence du volet Explorateur.

2. Ouvrez l'arborescence via Tree expand icon.png.

Étape 2 : Création de la procédure

1. Cliquez droit sur le dossier où doit être créée la nouvelle procédure.
          Create new procedure.png

2. Sélectionnez Nouveau > Procédure dans le menu contextuel.
La procédure est insérée dans le volet Explorateur, sous le libellé <Nouvelle procédure>.

3. Renommez la procédure.
Le volet Explorateur est réactualisé.

Étape 3 : Création des étapes de la procédure

1. Double-cliquez sur la procédure dans le volet Explorateur.
Le volet Conception est ouvert. Les étapes Début Step type icon - Start.png et Fin Step type icon - End.png sont automatiquement affichées.

2. Cliquez droit sur l'étape Début Step type icon - Start.png.

3. Sélectionnez Insérer une Étape dans le menu contextuel puis cliquez sur le type d'étape à ajouter  - Open url.png voir Description des différents types d'étapes
          Create new step.png


4. Renseignez l'étape suivant sa nature : cliquez ci-dessous pour afficher les instructions.

Voir le pas à pas détaillé dans Self Help

Action

1. Sélectionnez Insérer une Étape > Insérer une Action dans le menu contextuel. Keyboard shortcut icon.png

La nouvelle étape est insérée sur la représentation graphique.

Step Action.png

2. Nommez l'étape   - Open url.png voir Procédure

3. Définissez son contenu.

Action avec conditions

1. Sélectionnez Insérer une Étape > Insérer une Action avec Conditions dans le menu contextuel.

La nouvelle étape est insérée sur la représentation graphique.

Step Action with conditions.png

2. Nommez l'étape   - Open url.png voir Procédure

3. Définissez son contenu.

4. Définissez les branches :

  • Nommez chaque bouton de choix.
  • Définissez le contenu de chaque branche.
  • Définissez les étapes enchaînant derrière chaque bouton de choix.

Branche

1. Sélectionnez Insérer une Étape > Ajouter une Branche dans le menu contextuel. Keyboard shortcut icon.png

Un nouveau bouton de choix est inséré sur la représentation graphique, suivi d'une étape Fin Step type icon - End.png.

Step Branche - New.png

2. Nommez le bouton de choix   - Open url.png voir Procédure

3. Définissez son contenu.

4. Définissez les étapes de la nouvelle branche :

  • Cliquez droit sur le bouton de choix.
  • Sélectionnez Insérer une Étape dans le menu contextuel, puis sélectionnez le type d'étape - Open url.png voir Description des différents types d'étapes
  • Renseignez la nouvelle étape.
  • Ajoutez de la même façon toutes les étapes jusqu'à l'étape Fin Step type icon - End.png de la branche.

Step Branche - Continue till end.png

5. (Optionnel) Ajoutez une condition de visibilité sur la nouvelle branche :

  • Cliquez droit sur le bouton de choix et sélectionnez Ajouter une condition de visibilité dans le menu contextuel.
  • Définissez la condition via l'assistant.
  • Cliquez sur Terminer.

Un trait pointillé - - - - - est affiché sous le bouton de choix.

Step Branche - with visibility condition.png

Modification : Cliquez droit sur la branche et sélectionnez Modifier la condition de visibilité dans le menu contextuel.

Suppression : Cliquez droit sur la branche et sélectionnez Enlever la condition de visibilité dans le menu contextuel.

Page

1. Sélectionnez Insérer une Étape > Insérer une Page dans le menu contextuel. Keyboard shortcut icon.png

La nouvelle étape est insérée sur la représentation graphique.

Step Page.png

2. Nommez l'étape   - Open url.png voir Procédure

3. Définissez son contenu.

Page de choix

1. Sélectionnez Insérer une Étape > Insérer une Page de Choix dans le menu contextuel. Keyboard shortcut icon.png

La nouvelle étape est insérée sur la représentation graphique.

Step Choice page.png

2. Nommez l'étape   - Open url.png voir Procédure

3. Définissez son contenu.

4. Définissez la première branche :

  • Nommez le bouton de choix.
  • Définissez son contenu.
  • Définissez les étapes enchaînant derrière le bouton de choix :
  • Ajoutez de la même façon toutes les étapes jusqu'à l'étape Fin Step type icon - End.png de la branche.

    Step Branche - Continue till end.png

5. Réalisez les mêmes actions pour la seconde branche.

6. (Optionnel) Ajoutez une nouvelle branche.

  • Positionnez-vous sur le bouton de choix en-dessous duquel doit être insérée la nouvelle branche.
  • Sélectionnez Insérer une Étape > Ajouter une Branche dans le menu contextuel. Keyboard shortcut icon.png
  • Définissez les informations de cette nouvelle branche comme pour les 2 branches précédentes.

7. (Optionnel) Modifiez l'ordre des branches sur la représentation graphique.

  • Cliquez-glissez la branche vers un emplacement autorisé signalé en rouge.

    Step Branche - Change order.png

Point de reprise

1. Sélectionnez Insérer une Étape > Insérer un Point de Reprise dans le menu contextuel. Keyboard shortcut icon.png

Le nouveau point de reprise Step type icon - Resume point.png est inséré sur la représentation graphique.

2. Cliquez-glissez le point de reprise vers l'étape où vous souhaitez que la procédure continue.

Un trait rouge est affiché entre le point de départ et le point d'arrivée. La flèche indique le sens de la redirection.

Step Resume point.png

Sous-procédure

1. Sélectionnez Insérer une Étape > Insérer une Sous-Procédure dans le menu contextuel.

La nouvelle étape est insérée sur la représentation graphique.

Step Sub procedure.png

2. Double-cliquez sur la sous-procédure.

Note : Si la sous-procédure n'existe pas, vous devez la créer   - Open url.png voir Procédure

Insert sub procedure.png

3. Sélectionnez la procédure souhaitée.

4. Cliquez sur Terminer.

La représentation graphique est réactualisée et affiche le nom de la procédure sélectionnée.

5. (Optionnel - pour une étape visible par l'utilisateur) Visualisez l'étape telle qu'elle apparaîtra à l'écran pour l'utilisateur :

  • Cliquez sur l'étape dans le volet Conception.
  • Cliquez sur Launch procedure dropdown list.png dans la barre d'outils puis sur Launch procedure icon.png Lancer la procédure.
    L'étape est affichée sous forme d'une page web.

6. Ajoutez les autres étapes de votre procédure, en vous positionnant à chaque fois sur l'étape à la suite de laquelle vous souhaitez insérer une nouvelle étape.
 

Modification du contenu d'une étape

  • Cliquez sur l'étape dans le volet Conception.
  • Effectuez vos modifications via le volet Description.
  • Sauvegardez les changements de l'onglet Contenu via Save disk icon.png dans la barre d'outils.
     

Modification du contenu d'une étape défini via une ressource

Attention : Toute modification apportée à une ressource est automatiquement reportée dans toutes les procédures où elle est utilisée.

  • Ouvrez la ressource depuis le volet Explorateur.
  • Effectuez vos changements.
  • Sauvegardez la ressource.


Étape 5 : Test de la procédure

1er objectif : Tester le déroulement des étapes


2ème objectif : Tester le lien URL

1. Définissez la procédure comme point d'entrée pour les utilisateurs :

  • Cliquez droit sur la procédure dans le volet Explorateur.
  • Sélectionnez Autoriser l'accès des utilisateurs dans le menu contextuel.
    User procedure access icon.png s'affiche à droite du nom de la procédure.

2. Cliquez sur Launch procedure dropdown list.png dans la barre d'outils et cliquez sur Générer un lien vers la procédure.

3. Renseignez les informations de la boîte de dialogue.

4. Cliquez sur Copier un lien réutilisable.
L'URL affichée dans le champ Lien généré est copié dans le presse-papier.

5. Collez l'URL dans la barre d'adresse de votre navigateur internet et validez.

6. Renseignez les informations d'authentification.
La première étape de la procédure est ouverte dans votre navigateur internet.

7. Naviguez au travers des étapes pour vérifier le bon déroulement.

8. Cliquez sur Terminer pour refermer la boîte de dialogue.

Comment nommer une étape

1. Double-cliquez :

  • soit sur l'étape sur la représentation graphique (1) ;
  • soit sur la barre de titre du volet Description (2) .
             Rename step.png

2. Saisissez le nom de l'étape.

Best Practice icon.png  Vous pouvez masquer une partie du nom en plaçant le texte entre les caractères [ ].

3. Validez avec la touche < Entrée >.
Le nom est automatiquement mis à jour dans les 2 volets Conception et Description.

Comment créer une sous-procédure

Étape 1 : Sélection de la procédure

1. Double-cliquez sur la procédure dans l'arborescence du volet Explorateur.
La procédure est affichée dans le volet Conception.

Étape 2 : Sélection des étapes de la sous-procédure

1. Sélectionnez sur le diagramme du volet Conception toutes les étapes à inclure dans la sous-procédure, en maintenant la touche < Ctrl > enfoncée.
Toutes les étapes sélectionnées sont encadrées en bleu sur le diagramme.

2. Cliquez droit sur l'une des étapes de la sous-procédure et sélectionnez Créer une nouvelle procédure à partir de la sélection dans le menu contextuel.

3. Nommez la sous-procédure.

4. Cliquez sur Terminer.
Les étapes sélectionnées sont regroupées.
         Step Sub procedure.png

 Afficher le contenu de la sous-procédure

  • Cliquez sur l'étape lorsque le curseur a la forme Cursor hand icon.png.

Comment personnaliser le contenu d'une étape

Voir le pas à pas détaillé dans Self Help

Utiliser une ressource en pièce jointe

1. Glissez la ressource depuis le volet Explorateur vers le cadre délimitant l'étape.
La mise en page de l'étape est automatiquement gérée par le thème associé à la procédure.

Créer un tableau

1. Cliquez sur Table icon.png.

2. Cliquez sur une cellule et sélectionnez Modifier le tableau dans le menu contextuel.

  • Définissez la largeur du tableau, la taille de la bordure, ...
  • Supprimez une ligne via le menu contextuel d'une cellule  Ligne > Supprimer les lignes.
  • Fusionnez des cellules via le menu contextuel d'une cellule Cellule > Fusionner à droite
  • Modifiez la taille d'une cellule via le menu contextuel d'une cellule Cellule > Modifier la cellule.

Créer une image cliquable

Voir le pas à pas détaillé dans Self Help

1. Cliquez droit sur l'image insérée dans l'onglet Contenu du volet Description.
La barre d'outils contextuelle est affichée.
         Image - Create clickable zone - icon.png

2. Cliquez sur Clickable image icon.png.
Une nouvelle barre d'outils est affichée.

3. Délimitez avec la souris les zones cliquables de l'image.

  • Cliquez sur Clickable zone rectangle icon.png pour définir une zone rectangulaire.
  • Cliquez sur Clickable zone circle icon.png pour définir une zone circulaire.

         Image - Create clickable zone - areas.png

4. Indiquez l'action à effectuer lorsque la zone est cliquée, via Clickable image icon.png : ouvrir une page dans l'explorateur internet via une URL / aller sur une autre étape.
         Image - Create clickable zone - link.png

5. Cliquez sur Modifier.
 

Cas n° 1 : Des branches (étapes de choix) existent à la suite de l'étape dans laquelle est insérée l'image cliquable
Vous devez indiquer l'orientation vers une branche de la procédure (cochez Masquer la branche correspondante pour autoriser l'accès uniquement depuis l'image).

  • Renseignez dans le champ Infobulle le texte affiché lorsque la zone cliquable est survolée avec la souris.
  • Sélectionnez l'action à effectuer lorsque la zone est cliquée :
    • URL : l'utilisateur ouvre l'adresse URL dans une nouvelle page web ;
    • Sélectionner une branche : l'utilisateur enchaîne sur les étapes de la branche sélectionnée. Cochez la case Masquer la branche correspondante pour faire disparaître la branche sélectionnée.
  • Cliquez sur OK.
     

Cas n° 2 : Aucune branche n'est définie à la suite de l'étape dans laquelle est insérée l'image cliquable
La procédure continue sur l'étape suivante.

  • Renseignez dans le champ Infobulle le texte affiché lorsque la zone cliquable est survolée avec la souris.
  • Sélectionnez l'action à effectuer lorsque la zone est cliquée :
    • URL : l'utilisateur ouvre l'adresse URL dans une nouvelle page web ;
    • Passer au noeud suivant : l'utilisateur enchaîne sur l'étape suivante. Cochez la case Désactiver le bouton Suivant.
  • Cliquez sur OK.

5. Reproduisez toutes les actions pour chaque zone cliquable de l'image.

L'image cliquable est identifiée par :

  • une icône dans le cadre de l'étape dans le volet Conception ;
  • une bordure rouge dans le volet Description.

Comment obtenir les statistiques d'utilisation d'une procédure

Voir le pas à pas détaillé dans Self Help

Étape 1 : Sélection des critères

1. Renseignez vos critères de sélection (période, inclure la version de travail).

2. Cliquez sur Demander les statistiques.
 

Étape 2 (Optionnelle) : Obtention des statistiques d'une exécution de procédure

1. Renseignez l'identifiant de la procédure sur l'écran.

2. Cliquez sur Ouvrir une exécution de commande.
 

Étape 3 (Optionnelle) : Enregistrement des résultats dans un fichier

Totalité des résultats

1. Cliquez sur Exporter tout.
 

Sélection d'exécutions de procédures

1. Cochez les exécutions de procédures dans le tableau.

2. Cliquez sur Exporter la sélection.

Tags:
Modifié par Utilisateur inconnu le 2020/03/24 12:19
Créé par Administrator XWiki le 2018/12/14 11:21

Raccourcis

L'actualité mensuelle
•  Newsletter

Tous les changements
•  Service Manager
•  Service Apps
•  Self Help

Glossaire

Powered by XWiki ©, EasyVista 2020