The Studio's Edit Mode of Self Help


The Studio's edit mode is used to access the unpublished versions of Self Help projects associated with the current domain.

It is made up of several panes enabling you to:

Notes

  • The standard configuration of the edit mode in the Studio can be personalized by customers.
  • Multilingual management enables you to translate the components in each Self Help project into different languages, e.g. translation of component names, procedures, forms, etc.
  • Once the version of a Self Help project is published, it can no longer be modified. You can access it in publish mode.
        Open url.png See Version management.

Best Practice

  • Move the panes to the spot you want.
  • You can also modify the default size of the panes:
    • Explorer pane: 1/3 of the screen width
    • Conception pane: 2/3 of the screen width and 1/3 of the screen height
    • Description pane: 2/3 of the screen width and screen height
  • Select View > Reset Views in the menu to return to the default display mode.

Screen description

      Studio mode - Edit.png

Access: Select Mode > Edit in the menu

In the standard configuration, the Studio's edit mode displays four zones:

  • (1) Title bar and menu bar.
  • (2) Explorer pane with a view bar at the top that is used to:
    • Manage Self Help project versions and components in the current domain via the tree structure. 
    • Define the properties of components.
    • Access an overview of the current procedure.
  • (3) Conception pane with a workspace for designing procedures, HTML content and forms.
  • (4) Description pane specific to the object selected in the Conception pane, used to define its content and layout and manage the resources used.

Title bar and menu bar

     Studio - Bars.png

(1) Title bar: Information on the current Self Help session, i.e. server name, domain, logged-in user.

(2) Menu bar (Note: Certain menu options can also be accessed via a contextual menu specific to components in the Explorer pane).

Description of the menu bar

File menu: Commands used to:

  • Create a new object.
  • Import an archive to the domain or export a Self Help project to an archive.
  • Publish a Self Help project.
  • Modify the email address and password of the writer logged in to the Studio.
  • Change the domain.
     

Edit menu: Commands used to:

  • Undo and redo modifications.
  • Copy and paste text.
  • Rename and delete objects.
     

Procedure menu (Note: Only if a procedure is displayed in the Conception pane): Commands for performing actions on the steps of a procedure.

View menu: List of views available in the Explorer pane and Description pane.

  • Click one of views to show or hide it.
  • The active view is highlighted by an icon displayed on a blue background.
  • The Explorer pane includes three views: Explorer, Properties and Overview.
  • The Description pane includes one view for each language available for the current Self Help project. Open url.png See the description.
     

Mode menu: List of modes available in the Studio. The active mode is highlighted by an icon displayed on a blue background.

  • Edit mode: Access all versions of Self Help projects currently being modified in the current domain. Open url.png See the description.
  • Publish mode: Access all published versions of Self Help projects in the current domain. Open url.png See the description.
  • Admin mode (Note: Only for domain administrators and owners of Self Help) projects. Open url.png See the description.
     

Help menu: Commands used to:

  • Access documentation containing step-by-step procedures on how the Studio works. Open url.png See the description.
  • Return to the Self Help) Home page.
  • Define preferences:
    • List of users automatically created by SSO displayed in the list of visible users, via the Admin configuration option (Note: Only domain administrators and system administrators can access this functionality)
    • Languages for translation
    • Programs for opening documents if they are different from those used by the operating system
    • Default configuration of macros
  • Display the error log.
  • View the server version and Studio version.

 

Explorer pane

The Explorer pane is made up of several zones.

  • (1) View bar: Explorer and Properties for projects, procedures or resources, and Overview only for procedures.
  • (2) Contextual toolbar specific to the selected view.
  • (3) Pane for displaying information specific to the selected view.

        Explorer Pane.png

 

Explorer view

This view displays all Self Help projects in the current domain in a tree structure.

To show or hide the view: View > Explorer in the menu

        Explorer Pane - Explorer view.png

Toolbar

  • Status icon.png: Used to display the list of statuses applicable to resources and procedures.
    • The status changes as the workflow progresses: Draft, To be approved, Rework, Approved, Published.
    • The initial status of all content created within a project is Draft.
    • All content imported within a project can retain their status (the status saved in the archive). They can also be initialized with one of the status of the workflow.
          Open url.png See the description of the content validation workflow.
       
    • Click Display status or Hide status to show or hide the status of the component.
               Content validation workflow - Status display via Explorer pane.png
      Note: You can also see the status in the Properties view > Info tab.
    • Click one of the statuses in the list to display only the content associated with the status.
       
  • Select language drop down.png: Used to select the language for displaying the names of components in the tree structure.
    • To add a language to the list, select Help > Preferences > Allowed Languages.
       
  • Synchronize icon.png: Used to refresh the Conception pane based on the component selected in the tree structure.
  • Minimize maximize icon.png: Used to minimize the Explorer view or to display it in Full screen mode. When minimized, icons will appear in a left sidebar.

Tree structure

It displays all of the components for a given Self Help project, i.e. folders, procedures, resources, etc.
         Explorer Pane - Explorer view - Tree.png

  • The current version of each Self Help project is indicated between brackets after the name.
    Note: You can access previously published versions in publish mode.
  • Click Tree expand icon.png or double-click the project name to display the tree structure of the Self Help project.
    • To make it easier to manage, you can group components in folders, e.g. Resources, Examples, etc.
    • The icon displayed next to each component indicates the type of component, e.g. procedure, variable, form, etc.
    • The User procedure access icon.png icon displayed after a procedure name indicates that it can be accessed by end users.
    • Right-click a component to display its contextual menu. A list of the actions authorized will appear, e.g. create, copy, move, import, etc.
  • To modify the component name, right-click the name and select Rename.
    • To translate a component name, you should first click Select language drop down.png in the toolbar to select the language. Open url.png See Multilingual management.
      Note: The word <sans nom> displayed next to a component shows that no translation is available. The name between brackets is the one in the Studio's display language.
               Explorer Pane - Explorer view - Component with no translated label.png

Properties view

This view displays general information and metadata for the component selected in the tree structure of the Explorer pane.

To show or hide the view: View > Properties in the menu

Properties view for Self Help projects

      Explorer Pane - Properties view - Project.png

Toolbar

  • Select language drop down.png: Used to select the language for displaying the content of properties for the Self Help project.
     

Title bar

  • Double-click the Self Help project name to modify it.
    • You can also modify the name via the tree structure. Right-click the Self Help project and select Rename.
    • To translate the name, you should first click Select language drop down.png to select the language.
  • The Warning icon.png icon will be displayed if the Self Help project has no name.
     
ExplorerPane_ProjectPropertiesView_Tabs

List of tabs

  • Info: Information on the Self Help project, i.e. previous version number and its origin, last modification date, etc. Note: You can not change this information.
  • Quota: Visual display of:
    • Disk space used by the version of the Self Help project.
    • Disk space used by other Self Help projects.
    • Disk space available on the server (Note: Except if the server has unlimited disk space).
  • Metadata Definition: List of metadata manually added to the Self Help project and activated.
    • You can export the activated metadata. They will apply to all procedures of the Self Help project. Open url.png See How to export metadata from a Self Help project.
    • To add metadata, click Add metadata icon.png in the toolbar.
    • Click Activate metadata icon.png to deactivate metadata. The metadata will automatically be moved to the Deactivated Metadata tab.
  • Deactivated Metadata: List of metadata manually added to the Self Help project and deactivated.
    • Deactivated metadata cannot be exported.
    • Click Activate metadata icon.png to reactivate metadata. The metadata will automatically be moved to the Metadata Definition tab.
  • Statistics: Statistics on the use of each procedure in the Self Help project, e.g. number of executions and their average duration, average number of executions, etc. Open url.png See the procedure.
EndExplorerPane_ProjectPropertiesView_Tabs

Properties view for procedures

      Explorer Pane - Properties view - Procedure.png

Toolbar

  • Select language drop down.png: Used to select the language for displaying the content of properties for the procedure.
  • Access procedure icon.png No access procedure icon.png: Used to indicate whether or not users are authorized to run the procedure directly. Click the icon to toggle from one status to the other.
     

Title bar

  • Double-click the procedure name to modify it.
    •  You can also modify the name via the tree structure. Right-click the procedure and select Rename.
    • To translate the name, you should first click Select language drop down.png to select the language.
  • The Warning icon.png icon will be displayed if the procedure has no name.
     
ExplorerPane_ProcedurePropertiesView_Tabs

List of tabs

  • Info: Information on the procedure, i.e. creation date, last modification date, location, and list of metadata general and specific to the type of procedure.
    • Double-click the metadata to enter its contents. Note: You can not change this information.
    • You can export metadata. Open url.png See How to export metadata from a Self Help project.
    • Click Parameters > Edit parameters to specify input and output parameters for the procedure.
    • Click Link > Click to generate a link to generate the URL and test the procedure in a Web browser.
    • Click Icon > Add icon to procedure icon.png to associate an icon with the procedure.
  • Uses: List of resources used by the procedure.
    • Click <Open procedure and show the steps this resource is linked to>. The Conception pane will display the procedure and the list of resources used by the procedure. Click one of the resources to highlight it in the Conception pane.
  • Used by: List of resources using the procedure.
    • Click <Open procedure and show the steps this resource is linked to>. The Conception pane will display the procedure and the list of resources using the procedure. Click one of the resources to highlight it in the Conception pane.
  • Statistics: Statistics on the use of the procedure, e.g. number of executions and their average duration, average number of steps in the procedure, etc.  Open url.png See the procedure.
    • Click Open procedure execution icon.png in the toolbar to open a specific execution in the procedure.
EndExplorerPane_ProcedurePropertiesView_Tabs

Properties view for resources

      Explorer Pane - Properties view - Resource.png

Toolbar

  • Select language drop down.png: Used to select the language for displaying the content of properties for the resource.
  • Open object icon.png: Used to open the resource.
    • HTML content, Form and Sub-procedure resources: Content is displayed in the Conception pane.
    • Link resources: The URL is displayed in the Conception pane.
    • Document resources: These are opened using the corresponding program, e.g. Excel, Word, Paint, etc.
       
  • Document resources:
    • Replace file icon.png: Used to select a new file. Its content will automatically be propagated to the places where it is used in the project.
    • Download file icon.png: Used to download the file.
       

Title bar

  • Double-click the resource name to modify it.
    •  You can also modify the name via the tree structure. Right-click the resource and select Rename.
    • To translate the name, you should first click Select language drop down.png to select the language.
  • The Warning icon.png icon will be displayed if the resource has no name.
     
ExplorerPane_ResourcePropertiesView_Tabs

List of tabs

  • Info: Information on the resource, i.e. creation date, last modification date, location, size, etc. Note: You cannot change this information.
  • Linked Resources (Note: Only for HTML content resources): List of resources linked to the resource.
  • Variable (Note: Only for Form resources): Properties of the variable.
    • Click the link to display the steps where the variable is used.
  • Used by: List of steps using the resource, for each procedure.
    • Click <Open procedure and show the steps this resource is linked to>. The list of steps using the resource will appear for each procedure. Click one of the steps to display the procedure in the Conception pane and highlight the step.
EndExplorerPane_ResourcePropertiesView_Tabs

 

Overview view

This view displays the flow chart of the procedure selected in the tree structure.

Best Practice icon.png  Use it to display an overview of lengthy procedures that require horizontal scrolling in the Conception pane.

To show or hide the view: View > Overview in the menu

        Explorer Pane - Overview view.png

Toolbar

  • Zoom: Used to adjust the zoom level for the flow chart displayed.
    • The red outline indicates the area displayed in the Conception pane.
    • Click and drag the outline to view the area you want in the Conception pane.
       
  • Overview Page icon.png: Used to adjust the zoom level automatically so that the flow chart is fully displayed in the Conception pane without requiring any scroll bars.
  • Overview Height icon.png: Used to adjust the zoom level automatically so that the height of the flow chart is fully displayed without requiring the vertical scroll bar.
  • Overview Width icon.png: Used to adjust the zoom level automatically so that the width of the flow chart is fully displayed without requiring the horizontal scroll bar.

 

Conception pane

The Conception pane is used to design three types of components, i.e. procedures, HTML content resources, and Form resources.

  • When you access the Studio in edit mode, the component displayed is the one last opened during the previous Self Help session.
  • The tab bar at the top of the pane displays the history of components previously opened in the Conception pane, irrespective of the Self Help project.
             Conception Pane - Component tabs.png
    • Select a tab to display the component in the workspace.
    • Click >> at the end of the bar to see the hidden components (the number is displayed behind the icon).

Best Practice icon.png  ClickSynchronize icon.png in the Explorer view to refresh the tree structure automatically each time you open one of the components using the tabs.

Conception pane for procedures

This pane enables you to design the flow chart for the current procedure by configuring each of its steps.
         Open url.png See How to create a procedure.

It is made up of several zones.

  • (1) Tab bar of previously opened components
  • (2) Toolbar
  • (3) Space for designing the procedure

        Conception Pane - Procedure.png

Best Practice

  • If the length of a procedure exceeds the width of the screen, select the Overview view in the Explorer pane to display the entire flow chart. You can then use the zoom to adjust the size of the flow chart.

Workspace

It is used to build the decision tree for the current procedure.

  • Click one of the steps to select it. A blue outline will appear.
             Conception Pane - Procedure - Active step.png
    • The toolbars in the Conception and Description panes will be refreshed based on the type of step you select.
    • Define the configuration and layout in the Description pane.
       
  • Icons displayed within the outline of a step show the type of resource used, e.g. form, document, etc.
             Conception Pane - Procedure - Step with resources.png
    • To associate a resource with a step, click and drag the resource from the tree structure of the Explorer pane to the outline of the relevant step in the Conception pane. The tab specific to the type of resource will automatically be refreshed in the Description pane.
               Conception Pane - Procedure - Drag and drop resource.png
    • You can also insert resources directly in the Description pane.
       
  • Double-click one of the steps to specify its name.
    • You can hide part of the name by placing the text to be hidden within square brackets [ ].
    • You can also enter the name in the title bar of the Description pane.
       
  • Warning icon.png Used to indicate that errors were detected, e.g. name not specified, error with a condition, etc. Move the cursor over the icon to display its details in a tooltip.
             Conception Pane - Procedure - Step with problem.png

Conception pane for HTML content resources

This pane enables you to enter text and define the layout for a HTML content page.
Note: Unlike procedure steps, the Description pane is not used.

It is made up of several zones.

  • (1) Tab bar of previously opened components
  • (2) Toolbar
  • (3) Space for designing the HTML content

        Conception Pane - Html content.png

Workspace

  • Enter the text directly in the workspace.
  • To add a resource:
    •  Click and drag the resource from the tree structure of the Explorer pane to the workspace.
    • Once the resource is added to the workspace, click it to display the configuration options.
               Conception Pane - Html content - Resource contextual menu.png
  • Use the toolbars and menus to format the text.Open url.png See the Content tab in the Description pane.

Conception pane for Form resources

This pane enables you to design the current form by configuring each of its fields.

It is made up of several zones.

  • (1) Tab bar of previously opened components
  • (2) Toolbar
  • (3) Space for designing the form

        Conception Pane - Formulaire.png

Workspace

It is used to build the contents of the current form.

  • To add a row or column to the form, click Add icon.png at the bottom or to the right of the form respectively.
  • To add a field, right-click the new row or column and select Add from the contextual menu.
  • Click one of the fields to select it. A blue outline will appear.
             Conception Pane - Formulaire - Active field.png
    • The toolbars in the Conception and Description panes will be refreshed based on the type of field you select.
    • Define the configuration and layout in the Description pane.
       
  • Double-click the title bar of the field in the Description pane to specify its name.
    • You can hide part of the name by placing the text to be hidden within square brackets [ ].
  • Warning icon.png Used to indicate that errors were detected, e.g. name not specified, error with a condition, etc. Move the cursor over the icon to display its details in a tooltip.
             Conception Pane - Formulaire - Field with problem.png

 

Description pane

The Description pane enables you to define the contents of the object you selected in the Conception pane, e.g. procedure step or form field.

Description pane for procedure steps

This pane enables you to enter the content of the step, define its layout and specify the resources used.
         Open url.png See How to create a procedure.

It is made up of several zones.

  • (1) Tab bar displaying the translations of the step's contents
  • (2) Title bar
  • (3) Tab bar
  • (4) Contextual toolbar specific to the current tab
  • (5) Space for defining the contents of the current tab

        Description Pane - Procedure.png

 

Tab bar displaying translations

        Description Pane - Procedure - Translation tabs.png

  • One tab is displayed for each language in the Self Help project whose view you enabled by selecting View > Description (language) in the menu.
  • When you add a new language to the Self Help project, the contents from the tab of the initial language will automatically be copied to the tab of the new language.
    • Use the automatic translation tool to translate the text into the new language. Open url.png See the procedure
    • To add a language to the Self Help project, select Help > Preferences > Allowed Languages in the menu.
  • Each language can have its own content, layout and resources.

Title bar

  • Double-click the name of the step to modify it.
    • You can hide part of the name by placing the text to be hidden within square brackets [ ].
    • You can also double-click the step in the Conception pane to modify its name.
  • The Warning icon.png icon will be displayed if the step has no name in the selected language.
             Description Pane - Procedure - Component with no title.png

List of tabs

        Description Pane - Procedure - Tabs.png

  • Each tab has a contextual toolbar.
  • The resources associated with each step are displayed in dedicated tabs.
    Note: An icon indicating the type of resource is also displayed in the outline of the step in the Conception pane.

example Step with a Connector resource and a Document resource.

  • Resources are displayed in the Connectors and Linked documents tabs.
  • The corresponding icons are displayed in the outline of the step. Conception Pane - Procedure - Step with resources.png
  • To add a resource to one of the tabs, click and drag it from the tree structure of the Explorer pane to the relevant tab.
             Description Pane - Procedure - Drag and drop resource.png


Content tab

Editor for defining the HTML content of the object and its layout, e.g. text, tables, links, resources, etc.
Note: This tab appears only for Action, Action with Switch, Branch, Page, Page with Choices steps.

        Description Pane - Procedure - Content tab.png

  • Icons are grouped in menus based on their functionality.
    • Home menu: Functions for formatting text, e.g. font, bold, underlined, bullets, alignment, etc.
    • Insert menu: Functions for inserting resources, e.g. Self Help project resources, layout zones, horizontal lines, special characters or icons from the icon gallery.
    • Layout menu: Functions for defining the layout of content, e.g. layout templates, image or text layout zones, etc.
          Open url.png See How to use layout templates.
    • View menu: Zoom, automatic translation tool, printing, HTML code editor, keyboard shortcuts.
          Open url.png See How to use the automatic translation tool.
  • To insert a resource in the editor:
    • Click and drag the resource from the tree structure of the Explorer pane to the Content tab.
    • Click the name to configure it using the contextual toolbar.
  • To define clickable areas for images:
    • Click Clickable image icon.png in the contextual toolbar of the image.
    • Define the areas that users can click to run an action, such as opening a Web page, proceeding to the next step, selecting a branch of the tree, etc.  Open url.png See the procedure.
       

Linked documents tab

List of Document resources used in the current step, e.g. image, audio or video files, PDFs, etc.
Note: This tab appears only for Action, Action with Switch, Page, Page with Choices steps.

        Description Pane - Procedure - Link Files tab.png
 

Forms tab

List of Form resources used by the current step.
Note: This tab appears only for Action, Action with Switch, Page, Page with Choices steps.

        Description Pane - Procedure - Forms tab.png

  • Display colors:
    • Red: Parameters
    • Blue: Variables
       

Branches tab

List of branches linked to the step.
Note: This tab appears only for Action, Action with Switch, Page, Page with Choices steps.

        Description Pane - Procedure - Branches tab.png

Connectors tab

List of connectors used by the current step with their parameters and variables.
Note: This tab appears only for Action, Action with Switch, Page, Page with Choices steps.

        Description Pane - Procedure - Connectors tab.png

  • Display colors:
    • Green: Connectors attached to the object via the Conception pane.
    • Blue: Connectors inserted in the step content via the Description pane.
       

Linked procedure tab

List of sub-procedures used by the current step.
Note: This tab appears only for Sub-procedure steps.

         Description Pane - Procedure - Related procedures tab.png

Linked Go to steps tab

List of markers inserted in the current step.
Note: This tab appears only for Marker steps.

        Description Pane - Procedure - Related resume points tab.png

Report tab

Text inserted in the execution report when users perform the current step. This is not visible in the Web page.
The execution report describes the user journey in the procedure, i.e. all of the steps and branches consulted. It can be defined for each step via this tab.

  • By default, the report contains the name of the step.
  • You can customize the report for the current step using three options:
    • Custom Report: Enter the text to be inserted in the report manually.
    • Step title report: The name of the current step is automatically inserted in the report.
    • None: No text is displayed in the report.

Best Practice icon.png  Add a report to steps in the procedure for which you want to know the user's choice. 

Macro tab

Editor for defining macros.
Note: This tab appears for all steps, except Branch steps.

        Description Pane - Procedure - Macro tab.png

Best Practice icon.png Use macros to run calculations or to modify the user journey based on the user's answers in forms.

Description pane for form fields

This pane enables you to enter the contents of a field, define its layout, specify display conditions and input and output variables.

It is made up of several zones.

  • (1) Tab bar displaying the translations of the field's contents
  • (2) Title bar
  • (3) Tab bar
  • (4) Space for defining the contents of the current tab

        Description Pane - Formulaire.png

List of tabs

        Description Pane - Formulaire - Tabs.png

Display tab

        Description Pane - Formulaire - Display tab.png
 

Type and Validation tab

        Description Pane - Formulaire - Type validation tab.png

Input/Output tab

        Description Pane - Formulaire - Input output tab.png

Procedures

How to open the Self Help Studio

1. Run the Self Help executable.
The login window will appear.

2. Select the server where you want to work.

3. Specify your login information.

4. Click OK.

*The Studio will open. 

  • Your login information will appear in the title bar, i.e. server, domain, user.

How to use layout templates

Layout templates enable you to define the appearance of page content zones quickly based on the devices used, e.g. define zones automatically to display text or images, or define the size of these zones.
They can also be used to preload page contents with the names of the project, procedure or current step.

Note:

  • A template library is shipped with the standard Self Help project. You can add your own templates.
  • By default, templates are responsive in design.
     

example  Define a content zone using a template with three zones: (1) Header(2) Image zone(3) Text zone

Layout template - Example.png

 

Step 1: Select a layout template.

1. Go to the Description pane and select the Layout tab.

2. Click Layout templates icon.png.

3. Click the predefined template you want, e.g. D1, D2, etc.
         Layout template - Standard.png

4. In the Headlines section, click the number of headings you want to insert in the page.

Caution: Text placed within the square brackets [ ] in each heading will not be hidden when the procedure is run.
 

  • Number of headings = 1 ==> The name of the current step will automatically be inserted in the page contents as heading H1.
            Layout templates - One headline.png
  • Number of headings = 2 ==> The names of the procedure and current step will automatically be inserted in the page contents as headings H1 and H2.
            Layout templates - Two headlines.png
  • Number of headings = 3 ==> The names of the project, procedure and current step will automatically be inserted in the page contents as headings H1, H2 and H3.
            Layout templates - Three headlines.png
     

Step 2 (optional): Customize the template.

1. Complete the layout by inserting other zones.

        Layout template - Customize.png

  • (1) Insert a zone to the left of, inside, or to the right of the zone where the cursor is currently found.
  • (2) Left align or right align the zone.
  • (3) Width of the zone.
  • (4) Default initial content of the zone, i.e. empty, or displaying the project name, procedure name or step name.
Tags:
Last modified by Christine Daussac on 2020/03/24 12:35
Created by Administrator XWiki on 2019/12/10 17:29

Shortcuts

Recent changes
•  Service Manager
•  Service Apps
•  Self Help

Glossary

Powered by XWiki ©, EasyVista 2020