ev|Self Help - Cobalt - Présentation des nouveautés


Note : Ceci est un document de sortie de version.
  • Certaines copies d'écran peuvent être légèrement différentes de la version finale car l'amélioration du design est un processus continu jusqu'à la date de sortie.
  • Les pages du wiki détaillant les différents points vont être mises à jour prochainement. Pour vous tenir informé sur leur disponibilité : Open url.png Nouveautés du wiki

Cobalt 1.1
(2020-09-01)

ReleaseNotes_1_1

Nouveautés Service Bots

   Open url.png voir en détail : Présentation des nouveautés Service Bots - version Cobalt 1.1

  • Les agents virtuels Service Bots peuvent maintenant être liés avec l’outil collaboratif Microsoft Teams. Ils apparaissent alors comme n’importe quel autre membre de la société, et peuvent interagir naturellement avec les utilisateurs via le chat.
  • Il est maintenant possible de gérer les dictionnaires dans le module Service Bots, via le module d’administration > Administration > Service Bots > Dictionnaire.
  • Des informations dynamiques peuvent maintenant être collectées dans une conversation avec un agent virtuel grâce à l’intégration de formulaires dans les procédures dédiées.

Nouveautés module d'administration de Self Help

Ajout de formats d’exécution dans la création d’un profil d’extraction

Lors de la création d’un nouveau profil d’extraction de statistiques, plusieurs formats d’exécution sont maintenant proposés, permettant différents niveaux de granularité des résultats remontés.

Principe de mise en oeuvre

1. Accédez au module d'administration puis allez sur le menu Analytique > Profils d’extraction.

2. Cliquez sur Nouveau profil : un nouveau champ Format d'exécution apparait dans le panneau latéral.

     part 2_html_6896ecad.png

  • Option Steps : Remonte un enregistrement à chaque étape visible parcourue par l’utilisateur.
  • Option Executions : Remonte un enregistrement à chaque exécution d’un point d’entrée par l’utilisateur.
  • Option Stepsdebug : Format réservé au Support pour le débogage, permettant de remonter des enregistrements supplémentaires.

Nouveautés studio Self Help

Visualisation des utilisateurs créés par SSO

Depuis le mode Administration du studio Self Help, il est maintenant possible de faire apparaître dans la liste des utilisateurs visibles la liste des utilisateurs créés automatiquement par SSO.

Note : Cette fonctionnalité est accessible à un administrateur domaine ou système.

Principe de mise en oeuvre

1. Ouvrez le studio en mode Administration.

2. Cliquez sur le menu Aide > Préférences.

3. Cliquez sur la section Configuration de l’administration.

4. Cochez la case Voir les comptes SSO : les utilisateurs créés par SSO sont affichés dans la liste des utilisateurs du domaine.

     part 2_html_6ec6ad92.png

Nouvelles métadonnées de procédures

De nouvelles métadonnées de procédures sont présentes nativement dans le studio et s’appliquent à toute nouvelle procédure crée.

     part 3_html_541bf3130.png

(1) Tags : Métadonnée de type String, localisable. Permet de renseigner un ou plusieurs mots clés pour générer un nuage de tags.

(2) Agent Flag : Métadonnée de type String, non localisable, spécifique aux procédures destinées à un agent virtuel. Permet de définir le mode d’exécution des procédures.

(3) Dialog Friendly : Métadonnée de type Booléen, spécifique aux procédures destinées à un agent virtuel. Si la case est cochée, la procédure s’ouvre dans le panneau conversationnel.

(4) Alternatives Intents : Métadonnée de type String, localisable, spécifique aux procédures destinées à un agent virtuel. Permet de renseigner des formulations alternatives à une même demande faite à l’agent. 

Nouvelles variables projet

De nouvelle variables prédéfinies ont été ajoutées à la librairie de projet Self Help.

     part 2_html_m520d91a0.png

executionContext.channel

Cette variable permet de renseigner le mode de visualisation de la procédure.

  • PORTAL : procédure visualisée dans le portail.
  • APICONTENT : procédure appelée via l’API Contenu.
  • MSTEAMS : procédure visualisée via MS Teams.
  • SERVICEBOTS : procédure visualisée via un agent virtuel.
  • AUTOMATIC : procédure visualisée via l’API Portail.
  • PREVIEW : procédure visualisée en test.
  • DEBUG : procédure visualisée en mode Debug.
     

ExecutionContext.isDebug

Cette variable permet de lancer une procédure en mode Debug.

  • True : la procédure est lancée en mode Debug à partir du studio. Les phases de test sont alors simplifiées en appliquant un affichage conditionnel à une partie de la procédure (ex. : faire apparaître uniquement les pages d’informations).
  • False : la procédure est exécutée de façon standard.

Améliorations

Module d’administration

Tableau de bord par défaut

  • L’affichage du tableau de bord par défaut s’adapte maintenant à la résolution du terminal sur lequel il est visionné. Son graphisme a également été modifié.
             part 3_html_29eefab.png
  • Les filtres sont accessibles en cliquant sur le bouton Filtres <<. Des filtres prédéfinis ont été ajoutés.
             part 3_html_56a5d2ae.png
  • Une page d'aide est maintenant disponible via part 3_html_m544baf35.png situé en haut à gauche du tableau. Elle présente les 13 KPI utilisés dans le tableau de bord.
             part 3_html_788bc8bf.png

Nouveaux intitulés des menus du module d'administration

     part 3_html_13e23e7.png

  • Le menu Import a été renommé en menu Attributs.
  • Le sous-menu Attributs a été renommé en sous-menu Import d’attributs.

Envoi d’un rapport statistique par e-mail

Lors de l’exécution d’un profil d’extraction, il est maintenant possible d’envoyer le rapport par e-mail. Un lien de téléchargement du fichier est inséré dans l'e-mail.

Note : Le fichier doit avoir une taille inférieure à 3 Mo.

     part 3_html_54df310f.png

Gestion des fichiers Excel volumineux

Il est maintenant possible de générer et gérer des fichiers Excel de statistiques dont le nombre de lignes est supérieur à un million.

Suppression des exécutions de procédures depuis le studio

Toutes les exécutions de procédures faites depuis le studio par un rédacteur en mode Test sont désormais supprimées des statistiques.

Modification / ajout d’états de fin de procédure dans les fichiers de statistiques

Dans le fichier Excel résultant d’une extraction de statistiques, la colonne End type de la feuille executions a été revue pour prendre en compte toutes les manières dont une procédure peut être stoppée.

  • ENDED : fin normale de procédure.
  • EXITED : interruption volontaire d’une procédure.
  • CLOSED : session fermée pour inactivité.
  • SESSIONCLOSED : session fermée volontairement alors que des procédures sont en cours (les procédures sont alors mises sur pause et fermées 24h plus tard).
  • PAUSEDELETED : procédures en pause fermées volontairement.

Passage de paramètres lors de l’exécution d’une procédure

Le format du passage des paramètres d’entrée lors de l’exécution d’une procédure a été amélioré, scenarioParams étant désormais un objet JSON.

Il est maintenant possible d’indiquer le nom du paramètre à passer avant d'indiquer sa valeur ; les paramètre vides peuvent être ignorés.

     part 3_html_72a43f9d.png

Sécurité

Divers point de sécurité ont été traités :

  • Paramètres Apache
  • Restriction d’accès au server .log
  • Restriction d’accès à l’affichage de la liste des connecteurs
  • Restriction d’accès aux listes de rédacteurs
  • Amélioration de la sécurité des cookies

Recherche

Diverses améliorations ont été faites pour optimiser la recherche à partir du portail : prise en comptes des accents, des stop-words, …

Améliorations graphiques

Divers changements graphiques ont été faits afin d’améliorer la lisibilité du studio.

  • Les libellés des champs de la section Propriétés sont désormais en noir.
             part 3_html_541bf313.png
  • L’affichage de la liste des métadonnées d’un projet a été amélioré.
             part 3_html_1b3b04b2.png
  • Le bouton d'appel du portail sur la page d’accueil a été renommé en Portail rédacteur.
             part 3_html_1ec019a6.png
  • Plusieurs problèmes d’affichage et de redimensionnement de fenêtres ont été résolus.

Autres améliorations

  • Au niveau du serveur : dans la console Windows, il est possible de gérer les services SKY (mongo et tomcat).
  • Il est possible de mapper un attribut SAML avec un groupe d’utilisateur Self Help lors de la création d’un utilisateur.
  • Le traitement d’un import ou d’une synchronisation de très gros volume a été amélioré en supprimant le timeout par défaut.
  • Certains connecteurs ont été mis à jour pour fonctionner avec les plateformes 2.9.

Cobalt
(2020-08-10)

Nouveautés : module Service Bots

La solution Self Help intègre maintenant le module Service Bots qui permet le déploiement d'agents virtuels. 

Un agent virtuel est une nouvelle fonctionnalité qui permet d'ouvrir une fenêtre de dialogue entre une intelligence artificielle et l'utilisateur, dans le but de lui apporter toutes les connaissances par le biais d'une discussion (conversation textuelle). Il s'appuie pour cela sur un moteur de NLP (traitement automatique du langage naturel).
         part 1_html_m79cee8ae.png

Caractéristiques

  • L'agent virtuel peut être intégré dans un portail client, sur un domaine donné.
    • Plusieurs agents virtuels peuvent être créés.
    • Chaque agent se rapporte à un domaine donné, et à un ou plusieurs projet du même domaine.
  • Il peut également être intégré dans une page Html, pour un usage indépendant du portail.
  • L'interface s'appuie sur le thème evSH.
  • De nombreuses propriétés permettent de modifier les caractéristiques de l'agent : police dans l'interface conversationnelle, configuration du bouton d'appel, de l'entête et de la zone de saisie du panneau conversationnel, définition de la liste de mots clés affichés à l'ouverture de l'interface conversationnelle, ...

Principe de mise en œuvre

Dans un portail client

  • Allez sur la page d'accueil du studio et accédez au module Administration.
  • Cliquez sur le menu Agent virtuel > Liste > + Ajouter.
             part 1_html_796aeb96.png
  • Donnez un nom au nouvel agent.
  • Sélectionnez le domaine et les projets concernés.
  • Cliquez sur Ajouter.
             part 1_html_796aeb98.png

Dans une page Html

  • Un code JavaScript doit être inséré dans la section <head> de la page.
  • Ce code permet de renseigner le domaine, l'identifiant de l'agent, la langue, le compte public, le thème utilisé, ...

Voir le code JavaScript

<script type="text/javascript" src="https://www.myselfhelpdomain.com/va-themes/EVSelfHelp.widget.min.js"></script>
<script type="text/javascript">
  var ezEvie = new EVSelfHelp.Widget(
   {
    "assistant-id": "MyAgentID",
    "lang": "en_US",
    "is-test": false,
    "config-url": "https://www.myselfhelpdomain.com/va-themes/ezv-panel/config.json",
    "quicklinks": ["Text1","Text2"],
    "contextvars":
     {
      "shoptions": "public",
      "theme": "evsh"
     },
    "custom":
     {
    "ff": "verdana",
    "fs": "14px",
    "f_color": "#1e1f1f",
    "title": "https://www.domain.com/logo.png",
    "subtitle": "Your virtual agent",
    "subtitle_color": "#ffffff",
    "bg_color": "#6eb0da",
    "cb_name": "EVie",
    "cb_color": "#6eb0da",
    "cb_color_alt": "#2c658a",
    "user_color": "#ffffff", //f6f7f9
    "user_bgcolor": "#fa7268", //ffbb00
    "footer_color": "#ffffff",
    "placeholder": "Enter your question",
    "textarea_border": "1px solid #e8e8e8"
     }
   });
</script>

Paramètres à modifier

  • www.myselfhelpdomain.com : À remplacer par l’adresse du domaine Self Help hébergeant le projet
  • assistant-id : Identifiant de l'agent virtuel
  • lang : langue à utiliser (ex : fr_FR, en_US)
  • is-test : Indique si l'agent doit utiliser la version en cours d'édition des projets (valeur true - Note : L'utilisateur doit avoir les droits nécessaires) ou non (valeur false).
  • config-url : Emplacement du thème
  • quicklinks : Suggestions de saisies proposées à l'utilisateur
  • contextvars.shoptions : Compte public lorsque des données doivent être accessibles à des utilisateurs non connectés
  • contextvars.theme : Thème evSH à utiliser lors de l'affichage des procédures
  • custom : Paramètres permettant de personnaliser l'interface de dialogue

Quelques paramétrages de l'agent virtuel

Un ensemble de propriétés permettent de configurer l'agent virtuel.

  • Paramètres de configuration : domaine Self Help hébergeant le projet, langue de l'agent virtuel, personnalisation de l'interface de dialogue, …
  • Paramètres de personnalisation de l'affichage conversationnel de l'agent virtuel (dépendant du thème) : police, taille, couleur du texte, logo, nom de l'agent, …
  • Modes d'apparition de l'agent virtuel sur la page : ouverture du panneau en affichant une question, en initiant une nouvelle conversation, …

La connexion entre Self Help et Service Manager

Le package de connexion Self Help contient de nouveaux connecteurs d'intégration. Ils permettent d'interfacer n'importe quel projet Self Help avec Service Manager, grâce à l'API REST de Service Manager.

Le contenu du package de connexion

        part 1_html_m6b9792f.png

(1) Nom du projet (indiquant le nom du produit tiers, la date de la version, l'instance du produit tiers utilisée)
(2) Dossier [00] Low level : Contient les requêtes de base de l'API REST Service Manager
(3) Dossier [01] Examples and Help : Exemples de procédures et procédures d'aide d'utilisation du projet
(4) Dossiers par objet métier (Actions, Biens, Entités, Employés, …), contenant les fonctions de l'API REST utilisées pour des actions à plus haut niveau (Mettre à jour la fiche d'un employé, Créer un ticket, …)

Le paramétrage du package de connexion via la variable oSetup

Cette variable Objet contient tous les paramètres nécessaires à l'intégration. Elle se trouve dans le dossier Library.
         part 1_html_4fd4ee9f.png

(1) Variable Objet auth : contient toutes les informations de connexion
(2) Fonction buildAuthHeader() : permet de créer le header de la requête vers l'API REST
(3) Fonction buildUrl() : permet de créer l'URL de la requête vers l'API REST
(4) Variable isActive : permet de mettre en pause les requêtes (ex. : pendant les phases de test)
(5) Fonction isSetup() : permet de tester le bon fonctionnement de la configuration
(6) Variable Objet URL : contient toutes les informations sur l'adresse du serveur interrogé

Comment utiliser le package de connexion

  • Importez le package de connexion dans votre domaine.
  • Effectuez le paramétrage via la variable oSetup, nécessaire pour appeler l'API REST Service Manager.
  • Copiez le dossier [01] Examples and Help dans votre projet Service Manager pour tester le bon fonctionnement du paramétrage.
  • Créez vos procédures en faisant appel aux fonctions présentes dans le package de connexion grâce à leurs alias.
             part 1_html_72040973.png

Le workflow de validation des contenus

Un workflow de validation des contenus (procédures, ressources) est maintenant disponible.

  • Le statut évolue au fur et à mesure du déroulement du workflow : Brouillon, À approuver, À retravailler / Approuvé, Publié.
  • Tous les contenus créés dans un projet ont initialement le statut Brouillon.
  • Tous les contenus importés depuis un projet peuvent soit conserver leur statut (statut enregistré dans l'archive), soit être tous initialisés avec l'un des statuts du workflow.

Représentation graphique du processus

        FR - Content validation workflow.png

Description des étapes du processus

  • Étape Demande d'approbation réalisée par le rédacteur : Le rédacteur demande l'approbation d'un contenu par un expert ayant les droits d'approbation sur le projet. L'expert reçoit un e-mail indiquant qu'un nouveau contenu est en attente de validation.
         ==> Volet Explorateur > Clic droit sur le contenu > Demander l'approbation des changements
         ==> Nouveau statut du contenu : À approuver
             part 2_html_5ae36442.png
  • Étape Approbation des changements réalisée par l'expert : L'expert valide les changements effectués par le rédacteur.
         ==> Volet Explorateur > Clic droit sur le contenu > Approuver les changements
         ==> Nouveau statut du contenu : Approuvé
             part 2_html_7ec9489.png
    Note : Un rédacteur ayant les droits d'approbation sur le projet peut approuver lui-même le contenu
         ==> Volet Explorateur > Clic droit sur le contenu > Approuver les changements immédiatement
  • Étape Rejet des changements réalisée par l'expert : L'expert ne valide pas les changements effectués par le rédacteur. Il doit alors obligatoirement saisir un commentaire expliquant les raisons du rejet.
         ==> Volet Explorateur > Clic droit sur le contenu > Rejeter les changements
         ==> Nouveau statut du contenu : À retravailler
         ==> Le motif du rejet est affiché dans les propriétés du contenu.
             part 2_html_ma8d9c88.png
  • Étape Publication réalisée par l'administrateur : L'administrateur publie l'ensemble des contenus approuvés par les experts.
         ==> Un message est affiché lorsque des contenus ne sont pas approuvés (1).
         ==> Dans ce cas, l'administrateur peut forcer la publication pour publier le projet avec l'ensemble des contenus, sans que ceux-ci soient passés par l'étape Validation (2).
             part 2_html_m1d5d7e91.png
         ==> Nouveau statut de tous les contenus ayant auparavant le statut Approuvé : Publié - Note : Les autres statuts ne sont pas modifiés.
         ==> Après publication, l'utilisateur a accès à tous les contenus qui lui sont autorisés, quel que soit leur statut.
             part 2_html_69d9c81e.png

Comment visualiser le statut d'un contenu

Vous pouvez visualiser à tout moment le statut d'un contenu de 2 façons.

  • Via le volet Explorateur > icône part 2_html_27307870.png > option Afficher le statut
         ==> Le statut est affiché derrière chaque contenu.
         ==> Cliquez sur une icône de la liste pour afficher uniquement les contenus associés au statut sélectionné.
         ==> Cliquez sur l'icône part 2_html_m41da9e61.png pour masquer à nouveau les statuts.
             part 2_html_m4569d0c8.png
  • Via le volet Propriétés > onglet Info
             part 2_html_1771b2e7.png

L'import de masse de documents (outil Quick Start)

Cette nouvelle fonctionnalité permet de créer un projet Self Help à partir de l'import en masse de documents. Les fichiers word sont automatiquement importés comme des procédures. Tout le contenu du projet Self Help peut ensuite être copié dans un projet client existant. 

Note : Le projet Self Help issu d'un import de documents n'est pas publiable.

  • La structure du nouveau projet Self Help est créée à l'identique de l'arborescence des dossiers / sous-dossiers de l'explorateur de fichiers.
  • Chaque fichier word est importé dans Self Help sous la forme d'une procédure contenant une étape de type Page. Note : Une procédure peut être divisée automatiquement en plusieurs étapes en insérant des sauts de page dans le document word.
  • D'autres types de documents peuvent être insérés dans le dossier d'origine (.pdf, .ppt, .xls, images, ...). Ils sont alors importés sous forme de ressources.

Principe de mise en œuvre

  • Lancez l'outil EVSelfHelpMassImport disponible dans le répertoire d'installation du studio.
  • Sélectionnez le dossier à importer et le dossier de destination de l'archive Self Help. Puis cliquez sur Générer.
             part 2_html_m7fd4ddeb.png
    • L'archive Self Help est automatiquement générée via l'outil dans le dossier de destination.
    • Un sous-dossier result contenant l'archive est automatiquement généré dans le dossier de destination.
  • Allez sur le studio.
  • Importez l'archive Self Help dans le domaine du nouveau projet Self Help.
    • Les fichiers word sont automatiquement créés sous la forme de procédures comportant une étape de type Page.

Exemple

  • Description du projet à importer :
    • Arborescence des dossiers / sous-dossiers dans l'explorateur de fichiers.
               part 2_html_4613f4ab.png
    • Chaque sous-dossier contient :
      • 2 fichiers word : [a] Example… ; [b] Example…
      • Un fichier Image : Index
  • Importation du projet dans le studio via le nouvel outil Quick Start :
    • La structure du nouveau projet Self Help est automatiquement créée.
    • Les fichiers word ([a] Example… ; [b] Example…) et le fichier Image (Index) sont automatiquement importés dans chaque sous-dossier.
               part 2_html_m29640122.png
    • Une procédure est créée pour chaque fichier word importé.
               part 2_html_m117d9c09.png
    • Plusieurs étapes sont créées dans la procédure lorsque le fichier word contient des sauts de page.
               part 2_html_7e9f0f6d.png

Nouveau modèle de tableau de bord

Ce nouveau tableau de bord, à destination des administrateurs et nommé Modèle par défaut, affiche une synthèse des 11 principaux KPI utilisés pour évaluer un projet Self Help.

Sur un même écran, il permet à un administrateur d'avoir une vue Utilisateur final (1) et une vue Rédacteur (2) d'un projet.
         part 3_html_m78e761dc.png

Caractéristiques

  • L'entête du tableau de bord permet de filtrer les données suivant une période de temps, un domaine, un projet, un groupe d'utilisateurs.
  • Un filtre dynamique, activé en cliquant sur une partie du graphique, permet de filtrer l'ensemble du tableau de bord sur la valeur sélectionnée.

Description des KPI sur les exécutions des procédures : vue Utilisateur final

        part 3_html_m21d58fd9.png

(1) Nombre total d'exécutions de procédures par année, mois (valeur par défaut), semaine, jour
(2) Taux d'escalade : Répartition, par statut, des tickets créés via un parcours utilisateur
(3) Nombre d'exécutions de procédures par catégorie
(4) Nombre total d'exécutions de procédures sur une période donnée ; Durée moyenne d'exécution d'un parcours utilisateur
(5) Les 5 procédures les plus exécutées sur une période donnée, selon les groupes utilisateurs
(6) Répartition des procédures avec retours positifs / négatifs (Note : Les procédures sans retour sont celles abandonnées avant le questionnaire de satisfaction)
(7) Nombre moyen d'étapes exécutées pendant les parcours utilisateurs
(8) Les 5 procédures ayant le taux d'abandon le plus important sur une période donnée

Description des KPI sur la rédaction : vue Rédacteur

        part 3_html_mf329f5e.png

(1) Nombre de procédures publiées par catégorie (dossiers de niveau 1 du projet)
(2) Nombre de procédures publiées dans le projet et âge moyen de leur dernière publication
(3) Nombre moyen d'étapes de procédures par catégorie

Principe de mise en œuvre

  • Allez sur la page d'accueil du studio et accédez au module Administration.
  • Cliquez sur le menu Analytique > Profils d'extraction > + Nouveau profil.
             part 3_html_m1e44c465.png
  • Donnez un nom au nouveau profil d'extraction.
  • Sélectionnez le format de rapport Tableau puis sélectionnez le modèle d'extraction Modèle par défaut.
  • Cliquez sur Sauvegarder.
             part 3_html_6e43646d.png
  • Cochez le rapport qui vient d'être créé puis cliquez sur Télécharger.
    • Le rapport est téléchargé au format .twbx.
               part 3_html_5f721546.png

L'API Contenu

Les API sont utilisées pour exécuter des procédures Self Help dans un environnement tiers. L'API Contenu permet de compléter l'API Portail.

Cette nouvelle API récupère les actions élémentaires qui peuvent être faites sur une procédure, et en gère l'exécution dans un environnement tiers. Cela permet de naviguer dans la procédure sans avoir à changer de page : les boutons Suivant, Précédent, Choix d'une branche, ... sont directement intégrés dans la page.

Elle est livrée avec une bibliothèque JavaScript qui encapsule les méthodes pour les importer plus facilement dans une page Html. Le contenu de la page Self Help peut ainsi être facilement récupéré et inclus dans n'importe quelle section <div> d'un site.

Les requêtes incluses dans l'API Contenu

GET Start Scenario : Permet de démarrer un scénario
POST Continue Scenario : Permet d'aller au nœud suivant du scénario
POST Back Scenario : Permet de revenir au nœud précédent du scénario
POST Pause Scenario : Permet de mettre en pause un scénario
POST Reactivate Scenario : Permet de réactiver un scénario suspendu
POST Terminate Scenario : Permet d'arrêter un scénario 

Exemple d'intégration dans une page web

Lors de l'utilisation des boutons Précédent ou Suivant, seul le cadre dans lequel est contenu la procédure (cadre Import) est mis à jour. Le reste de la page (entête, pied de page) n'est pas rechargé, ce qui permet un affichage plus rapide.
         part 3_html_m7b3e97ca.png

Autres nouveautés

La fonction de traduction automatique

Le module de traduction s'appuie sur la technologie Microsoft Cognitive. Il détecte automatiquement la langue d'origine et permet de traduire le texte en 65 langues différentes.

Dans un projet multilingue, cette nouvelle fonctionnalité permet ainsi de traduire rapidement et de façon automatique chaque page dans l'ensemble des langues utilisées. La traduction peut ensuite être ajustée manuellement.

Principe de mise en oeuvre

  • Allez sur le studio.
  • Affichez dans le volet Conception la procédure à traduire.
  • Double-cliquez sur la procédure pour l'afficher dans l'onglet Description de la langue d'origine.
  • Rédigez la procédure dans cette langue.
             part 4_html_324620a8.png
  • Copiez-collez le contenu de la procédure dans l'onglet Description de la langue cible.
             part 4_html_324622a8.png
  • Cliquez sur le menu Affichage puis sur l'icône part 4_html_17227c1b.png.
    • La langue d'origine est automatiquement détectée.
               part 4_html_324624a8.png
  • Sélectionnez la langue cible puis cliquez sur Traduire.
    • Le texte de la procédure est automatiquement traduit dans la langue cible.
    • Vous pouvez ensuite effectuer les ajustements nécessaires.
               part 4_html_324626a8.png

La gestion des droits

Nouveau droit d'approbation

Il confère à un rédacteur le droit d'approuver / refuser l'ensemble des contenus (procédures, ressources) d'un projet donné.

  • Activation / Désactivation : via le volet Propriétés du projet > onglet Rédacteurs
             part 4_html_m3d3d1839.png
  • La hiérarchie des droits est maintenant la suivante :
             part 4_html_m3d3d1840.png

Nouveau droit de propriété

Il attribue la fonction de propriétaire à un rédacteur sur un projet donné.

  • Activation / Désactivation : via le volet Propriétés du projet > onglet Rédacteurs
             part 4_html_3e6504c8.png

La gestion des attributs (métadonnées)

Cette nouvelle fonction permet d'exporter les métadonnées d'un projet Self Help dans un fichier .csv afin de pouvoir les travailler plus facilement, puis de les réimporter dans le projet. Les métadonnées sont alors automatiquement réattribuées à l'ensemble des procédures du projet.

Principe de mise en œuvre

  • Exportez les métadonnées dans une archive Self Help.
    • Allez sur le studio.
    • Cliquez droit sur le projet dans le volet Explorateur, puis cliquez sur Exporter > Exporter les métadonnées.
    • Indiquez le répertoire de sauvegarde du fichier.
  • Ouvrez dans Excel le fichier .csv qui a été généré et effectuez les corrections et ajouts d'informations souhaités.
             part 4_html_m641450e0.png
  • Réimportez le fichier .csv dans le projet.
    • Allez sur la page d'accueil du studio et accédez au module Administration.
    • Cliquez sur le menu Import > Attributs > + Importer des attributs.
    • Sélectionnez le fichier .csv à importer et cliquez sur Importer.
               part 4_html_m680adcd4.png

Les blocs (widgets) dans les procédures

Le projet standard livré avec Self Help contient un dossier Widgets. Ce nouveau dossier contient des blocs permettant d'ajouter facilement des fonctions aux procédures et aux pages, via un simple cliquer-glisser.
         part 4_html_15ddb452.png

Liste des blocs disponibles dans le projet standard

  • Escalade du ticket
  • Questionnaire de satisfaction
  • Suppression du bouton Précédent sur une page (pour empêcher toute mauvaise manipulation)

La présentation Bouton dans les formulaires

Une nouvelle option Bouton est maintenant disponible dans la liste des apparences du sélecteur des champs de formulaire de type Liste de valeurs à choix unique et Liste de valeurs à choix multiples.
         part 4_html_305069a4.png
Elle permet d'afficher les choix possibles sous la forme de boutons. La taille des boutons peut être modifiée.
         part 4_html_m5395ac52.png

Évolutions

Évolutions sur le studio

Principales nouveautés

  • L'interface graphique du studio a été entièrement revue. Un accès direct au portail rédacteur est maintenant possible depuis la page d'accueil du studio.
  • Les vues Édition, Publication et Administration sont maintenant homogènes. Elles peuvent être entièrement personnalisées par le rédacteur.
  • Le design des différents volets de la vue Édition a été revu : allègement des bordures, amélioration du contraste entre les fenêtres, nouvelles icônes, couleurs en harmonie avec les couleurs du thème Oxygène de Service Manager.
  • Un nouvel éditeur graphique a été implémenté. Il s'appuie sur l'éditeur Froala et donne accès à de nouvelles fonctionnalités de mise en forme et de mise en page du contenu.
  • Une bibliothèque de modèles de mise en page du contenu est maintenant disponible.

Description de la nouvelle interface graphique du studio

La page d'accueil

        part 5_html_m1b250358.png

(1) Accès au studio
(2) Accès au portail rédacteur
(3) Accès à l'aide relative à la création d'un projet Self Help

Accès au portail rédacteur

        part 5_html_m2952719d.png

(1) Téléchargement du guide de démarrage rapide (pdf)
(2) Accès à l'aide
(3) Accès au module Administration pour générer des rapports statistiques

Les vues

  • La vue Édition
             part 5_html_m55ba4ab4.png
(1) Barres de titre et de menu
(2) Volet Explorateur (par défaut, sur 1/3 de la largeur de la fenêtre)
(3) Les 2 onglets Propriétés et Vue d'ensemble du volet Propriétés sont maintenant accessibles sous forme de vues
(4) Volet Conception (par défaut, sur 2/3 de la fenêtre en largeur et 1/3 en hauteur)
(5) Volet Description (par défaut, sur 2/3 de la fenêtre en largeur et en hauteur)
  • Les vues Publication et Administration
             part 5_html_46fd34f5.png
(1) Volet Explorateur (par défaut, sur 1/3 de la largeur de la fenêtre)
(2) Volet Détail (par défaut, sur 2/3 de la largeur de la fenêtre)

Description du nouvel éditeur graphique

  • La barre d'outils a été enrichie de nouvelles fonctionnalités.
  • Les fonctions sont maintenant regroupées dans des menus, ce qui permet de les retrouver facilement.
  • Les menus contextuels disponibles sur les zones de contenu ont été entièrement revus.
             part 6_html_m2c67ed8b.png

Les menus

  • Menu Accueil : fonctions de mise en forme du texte (menu visible à l'ouverture de l'éditeur)
             part 6_html_m480445e4.png
(1) Enrichissement de la bibliothèque de polices
(2) Nouvelles fonctions de mise en forme, accessibles via part 6_html_42c3c82e.png : Barré, Indice, Exposant, Hauteur de la ligne, Citation
  • Menu Insertion : fonctions d'insertion des ressources dans le projet
             part 6_html_m2a957ac8.png
(1) Ressource issue du projet
(2) Zone de mise en page
(3) Ligne horizontale
(4) Caractères spéciaux
(5) Accès à la bibliothèque d'icônes
  • Menu Mise en page : fonctions de mise en page du contenu
             part 6_html_7b40d082.png
(1) Accès aux modèles de mise en page
(2) Insertion d'une zone de mise en page selon son type (texte, image, vidéo, titre…)
  • Menu Affichage
             part 6_html_6df387a8.png
(1) Zoom de la zone Description
(2) Accès à l'outil de traduction automatique
(3) Impression de l'étape
(4) Accès à l'éditeur de code Html
(5) Accès aux raccourcis clavier

Les menus contextuels sur une zone

  • Ils permettent de définir les propriétés de la zone, avant de définir son contenu.
  • L'icône d'accès au menu est maintenant affichée dès que le curseur est placé à l'intérieur d'une zone.
             part 6_html_782cbb92.png
  • Un clic gauche sur l'icône part 6_html_782cbb90.png permet d'afficher les options.
    • Les icônes du haut agissent sur la mise en forme de la zone.
    • Les icônes du bas agissent sur le contenu de la zone.
               part 6_html_782cbb94.png
(1) Taille, marges, alignement de la zone
(2) Bordure et couleur de fond de la zone
(3) Masquage de la zone sur les mobiles
(4) Copie de la zone et son contenu dans le presse-papier
(5) Modification du type de zone
(6) Marges et alignement du contenu de la zone
(7) Modification du style du contenu de la zone
(8) Effacement / Suppression de la zone

Les menus contextuels sur un contenu

  • Ils sont accessibles via un clic gauche sur le contenu.
  • Ils diffèrent suivant le type de contenu.
    • Menu contextuel d'une image
               part 6_html_m4892b04.png
    • Menu contextuel d'un tableau
               part 6_html_54f13f0f.png
    • Menu contextuel des autres types de contenu
               part 6_html_m2fa44eca.png

Les modèles de mise en page

Les modèles de mise en page permettent de définir rapidement l'apparence et le comportement de la zone de contenu d'une page suivant les supports utilisés pour y accéder.

Exemple

        part 6_html_5bd85e88.png

(1) Entête
(2) Zone pour une image
(3) Zone pour du texte

Caractéristiques

  • Une bibliothèque de modèles est fournie dans le projet standard livré avec Self Help. Vous pouvez y ajouter vos propres modèles.
  • Les modèles sont responsive par défaut.
     

Principes d'utilisation des modèles

  • Allez sur le volet Description.
  • Cliquez sur l'onglet Mise en page puis sur l'icône part 6_html_67b28df9.png.
  • Cliquez sur le modèle prédéfini souhaité (1).
  • Cliquez sur le nombre de titres / sous-titres à insérer dans la page (2).
             part 6_html_28513e24.png
  • Vous pouvez également effectuer la mise en page en insérant directement les différentes zones.
             part 6_html_19c26e7a.png
(1) Insertion d'une zone avant, à l'intérieur ou après la zone dans laquelle le curseur est positionné
(2) Alignement de la zone à gauche ou à droite
(3) Largeur de la zone
(4) Contenu initial par défaut de la zone (vide, avec le nom du projet, de la procédure ou de l'étape)

Évolutions sur le thème evSH et le portail client

Principales nouveautés

  • Les couleurs du thème evSH sont maintenant en harmonie avec les couleurs du thème Oxygène de Service Manager.
  • Le thème est maintenant entièrement responsive.
  • L'interface graphique du portail client a été entièrement revue.
  • Une nouvelle fonctionnalité permet de filtrer le contenu du portail client selon les groupes auxquels l'utilisateur appartient.

Description de la nouvelle interface graphique du portail client

La page d'accueil

        part 7_html_m53624afb.png

(1)
Zone d'identification affichant :
  • le nom du projet
  • le nom de l'utilisateur
  • la langue d'affichage (modifiable)
  • les groupes auxquels l'utilisateur appartient (sélectionnables)
  • le bouton de déconnexion
(2) Zone des news
(3) Zone des sujets populaires
(4)
Liste des catégories / sous-catégories du projet Cliquez sur une sous-catégorie pour accéder aux pages Rubrique associées.

La page Rubrique

        part 7_html_m606b82e3.png

(1) Liste des filtres de catégories
(2) Liste des procédures avec leur description

La page Procédure

Une nouvelle fonctionnalité Historique part 7_html_287aba43.png a été ajoutée dans la barre d'icônes. Elle permet de consulter la liste des pages par lesquelles l'utilisateur est passé.
         part 7_html_2707bd3d.png

Nouvelle fonctionnalité de filtre du contenu du portail client

Cette nouvelle fonctionnalité ajoutée au thème evSH permet de filtrer le contenu du portail client suivant les groupes auxquels l'utilisateur appartient.

Exemple

Les procédures du dossier Rights & Training sont affectées au groupe BACK OFFICE ; les autres procédures du projet sont affectées au groupe FRONT OFFICE.

  • Les 2 groupes BACK OFFICE et FRONT OFFICE sont cochés : l'utilisateur voit l'ensemble du portail client.
             part 7_html_m2a5b8aeb.png
  • Seul le groupe BACK OFFICE est coché : l'utilisateur voit uniquement les procédures du dossier Rights & Training.
             part 7_html_m5b1caa54.png
  • Seul le groupe FRONT OFFICE est coché : l'utilisateur voit l'ensemble du portail client, à l'exception des procédures du dossier Rights & Training.
             part 7_html_5e12eb19.png

Principe de mise en oeuvre

  • Ajoutez une métadonnée authorizedGroups au niveau du projet, via l'icône dédiée dans l'onglet Propriétés.
             part 7_html_m494a9d9c.png
  • Qualifiez les groupes d'utilisateurs au niveau de chaque procédure.
    • Vous pouvez utiliser la fonction de gestion des attributs.
    • Ajoutez les groupes d'utilisateurs en les séparant par l'un des caractères , ; | /.

exemple La procédure ci-dessous est visible uniquement pour les utilisateurs du groupe FRONT OFFICE.
        part 7_html_5b08b73.png

Évolutions sur la recherche

Dès qu'une recherche est exécutée sur le portail client, une barre de filtre par catégorie (dossiers de niveau 1 du projet) est maintenant affichée.

  • Saisissez les mots clés recherchés et validez avec la touche < Entrée > : les catégories contenant des résultats sont affichées sous la barre de recherche, dans l'ordre décroissant du nombre de résultats correspondants.
  • L'icône de la catégorie correspond à l'icône associée au dossier. 
  • Une info-bulle affiche le nom du dossier au survol.
             part 8_html_m642e5121.png
  • Les résultats peuvent être filtrés en cliquant sur une catégorie.
             part 8_html_m2279ee07.png
  • L'icône part 8_html_42c3c82e.png permet d'accéder aux autres catégories qui ne sont pas visibles à l'écran.
             part 8_html_628a93db.png
Tags:
Modifié par Christine Daussac le 2021/10/26 18:24
Créé par Administrator XWiki le 2019/10/21 17:19

Raccourcis

L'actualité mensuelle
•  Newsletter

Tous les changements
•  Service Manager
•  Service Apps
•  Self Help
•  Service Bots

Powered by XWiki ©, EasyVista 2021