La gestion multilingue d'un projet Self Help


Dans le cadre d'un projet Self Help multilingue, l'ensemble des composants peut être traduit en plusieurs langues : libellés des dossiers, titres des procédures, contenu des étapes, champs des formulaires, ...

À cet effet, plusieurs méthodes complémentaires de traduction sont disponibles  - Open url.png voir Description :

  • réaliser une traduction composant par composant ;
  • réaliser une traduction via l'export / import d'une archive de traduction du projet Self Help ;
  • utiliser un outil de traduction automatique disponible sur les étapes de procédures et les ressources de type Contenu Html.

Remarques

  • Les langues proposées pour la traduction d'un projet Self Help sont disponibles via le menu Aide > Préférences > Langues autorisées en mode Édition du Studio Desktop.

Caractéristiques de chaque méthode de traduction

Traduction composant par composant

     Open url.png voir Procédure

  • La traduction est réalisée langue par langue.
  • Elle nécessite d'aller sur chacun des composants, et de les traduire un à un : éléments de l'arborescence, libellé des étapes des procédures, textes des étapes, contenu des ressources, ....

Traduction via l'export / import d'une archive de traduction

     Open url.png voir Procédure

  • Une archive de traduction est créée, comprenant l'ensemble des composants d'un projet Self Help.
  • Elle est réalisée pour une langue donnée.
  • Les traductions sont réalisées directement dans les fichiers exportés au format .xliff  - Open url.png voir Remarques importantes
  • Une fois traduite, l'archive est réimportée dans le projet Self Help.
     

Outil de traduction automatique

  • La traduction est effectuée langue par langue, via le volet Conception du mode Édition du Studio Desktop.
  • Le texte de la langue d'origine est automatiquement traduit dans la langue sélectionnée.
  • Les traductions peuvent ensuite être ajustées manuellement dans chacune des langues.

Attention

Traduction via l'export / import d'une archive de traduction

  • Les fichiers .xliff générés lors de l'export d'une archive de traduction comportent de nombreuses balises au format XML. Il est fortement recommandé de faire appel à une société de traduction pour les traiter via des logiciels spécialisés. De plus, ces logiciels possèdent une mémoire de traduction permettant de stocker des segments de phrase et de les réutiliser. De cette façon, seules les données localisables modifiées ou ajoutées entre 2 versions sont traitées.
  • Il est recommandé de verrouiller le projet Self Help tout le temps que dure la traduction. En effet, la moindre modification de son contenu rendrait l'archive de traduction caduque.

Procédures

Comment traduire un projet Self Help composant par composant

Voir le pas à pas détaillé dans Self Help

Étape 1 : Sélection des langues de traduction

1. Cliquez sur le menu Aide > Préférences.

2. Cliquez sur Langues autorisées.

3. Cochez les langues que vous souhaitez utiliser pour votre gestion multilingue des projets Self Help.

4. Cliquez sur Appliquer puis OK.
 

Étape 2 : Traduction du titre du projet Self Help et de ses composants

1. Sélectionnez la langue de traduction via Select language drop down.png dans la barre d'outils du volet Explorateur.

2. Traduisez le titre du projet Self Help.

  • Cliquez droit sur le titre.
  • Sélectionnez Renommer... dans le menu contextuel. Keyboard shortcut icon.png <F2>
  • Saisissez le libellé dans la langue sélectionnée.
  • Enregistrez via la touche <Entrée>.
    Le libellé traduit est enregistré. Le libellé de la langue de référence est affiché entre parenthèses et en gris.

3. Réalisez les mêmes actions pour traduire le nom de tous les composants du projet Self Help.
 

Étape 3 : Traduction des objets de la procédure

1. Sélectionnez la langue de traduction via Select language drop down.png dans la barre d'outils du volet Conception.

2. Traduisez l'ensemble des titres des objets placés sur le diagramme.

  • Cliquez droit sur chaque objet.
  • Sélectionnez Renommer... dans le menu contextuel. Keyboard shortcut icon.png <F2>
  • Saisissez le libellé dans la langue sélectionnée.
  • Enregistrez via la touche <Entrée>.
    Le libellé traduit est enregistré.
     

Étape 4 : Traduction du contenu des objets de la procédure

    Open url.png  voir également Traduction automatique du contenu Html et du contenu des étapes
 

1. Affichez le volet Description dans la langue de traduction via le menu Vue > Description....
Une nouvelle vue Description précédée du drapeau de la langue de traduction est affichée.
         Multilingual description pane.png

2. Cliquez dans le diagramme du volet Conception sur l'objet de la procédure dont le contenu est à traduire.
Le contenu de l'objet est affiché dans le volet Description de la langue de traduction.

3. Traduisez le contenu de l'objet dans l'onglet Contenu du volet Description.

4. Répétez ces actions pour l'ensemble des objets de la procédure ayant un contenu à traduire.
 

Étape 5 : Traduction des ressources du projet

     Open url.png voir Description des types de ressources

Ressources de type Fichier

1. Ajoutez le fichier traduit dans le volet Explorateur.

  • Ajoutez-le dans le même dossier que le fichier original.
  • Donnez-lui un autre nom.

exemple  Fichier original EN : Platform Pricing ; Nouveau fichier FR : Prix par plateforme

2. Remplacez le fichier original avec ce nouveau fichier dans la procédure traduite.

  • Cliquez sur le fichier original dans le volet Explorateur.
  • Cliquez sur l'onglet Utilisée par dans le volet Propriétés.
  • Cliquez sur la première étape où le fichier est utilisé.
    • 1er cas : Le fichier est attaché comme pièce-jointe à l'étape
      • Sélectionnez la langue de traduction via Select language drop down.png dans la barre d'outils du volet Conception.
      • Cliquez-glissez le fichier traduit vers l'étape dans le volet Conception.
    • 2ème cas : Le fichier est inséré dans l'éditeur de contenu de l'étape
      • Sélectionnez la vue Description précédée de l'icône du drapeau de la langue de traduction dans le volet Description.
      • Cliquez-glissez le fichier traduit vers l'onglet Contenu.
  • Répétez ces actions pour chacune des étapes où le fichier original est utilisé.
     

Ressources de type Contenu Html

1. Double-cliquez sur la ressource dans le volet Explorateur.

2. Sélectionnez la langue de traduction via Select language drop down.png dans la barre d'outils du volet Conception.

3. Effectuez la traduction dans le volet Conception.

Ressources de type Formulaire

1. Double-cliquez sur la ressource dans le volet Explorateur.

2. Sélectionnez la langue de traduction via Select language drop down.png dans la barre d'outils du volet Conception.

3. Traduisez le titre des composants du formulaire.

4. Double-cliquez sur le premier composant.
Le contenu de l'objet est affiché dans le volet Description de la langue de traduction.

5. Cliquez sur l'onglet Entrées/Sorties puis sur Modifier la liste.

6. Traduisez les libellés de chaque élément du composant et cliquez sur Terminer.

Comment traduire un projet Self Help par export / import d'une archive

Voir le pas à pas détaillé dans Self Help

Étape 1 : Export du contenu du projet Self Help dans une archive

1. Cliquez droit sur le projet Self Help et sélectionnez Traduction > Exporter les fichiers de traduction dans le menu contextuel.

2. Cochez la case Empêcher les modifications avant l'import de traduction pour verrouiller le projet Self Help tant que l'ensemble des fichiers exportés ne sont pas réimportés.

3. Sélectionnez la langue de traduction via Select language drop down.png.

4. Indiquez le nom et l'emplacement de l'archive de traduction.

5. Cliquez sur Terminer.

  • Un fichier .zip est créé à l'emplacement sélectionné. Il contient les contenus de tous les objets du projet Self Help générés dans des fichiers .xliff.
  • Le projet Self Help ne peut plus être modifié tant qu'il n'est pas réimporté. Son nom est affiché en rouge dans le volet Explorateur et la mention Verrou de traduction est affichée après son nom.

Attention : Ne déverouillez pas le projet Self Help tout le temps que dure la traduction. En effet, la moindre modification du contenu du projet rendrait l'archive de traduction caduque.
 

Étape 2 : Traduction du contenu des fichiers .xliff

Attention : Les fichiers .xliff comportant de nombreuses balises au format XML, il est recommandé de faire appel à une société de traduction pour les traiter via des logiciels spécialisés. 

1. Dézippez l'archive de traduction.
Les fichiers .xliff contenant les contenus de tous les objets du projet Self Help sont extraits.

2. Ouvrez le premier fichier .xliff.

3. Effectuez la traduction du contenu de l'objet.

4. Sauvegardez le fichier.

5. Réalisez les mêmes actions pour traduire et sauvegarder chaque fichier.
 

Étape 3 : Import de l'archive de traduction

1. Effectuez un zip de l'archive de traduction avec tous les fichiers .xliff traduits.

2. Cliquez droit sur le projet Self Help et sélectionnez Ouvrir le projet.

3. Cliquez droit sur le projet Self Help et sélectionnez Traduction > Importer une archive de traduction.

4. Sélectionnez le fichier zip de l'archive de traduction.
Le contenu de l'archive de traduction est affiché.

5. Cliquez sur Terminer.

  • Le contenu des fichiers de l'archive de traduction est réimporté.
  • Le verrou sur le projet Self Help est supprimé.

Déverrouillage manuel d'un projet Self Help

  • Cliquez droit sur le projet Self Help et sélectionnez Supprimer le verrou dans le menu contextuel.

Comment utiliser l'outil de traduction automatique

Étape 1 : Rédaction du contenu d'un objet dans la langue d'origine

1. Cliquez sur l'objet à traduire sur la représentation graphique du volet Conception.
L'onglet Contenu est ouvert dans le volet Description.

2. Cliquez sur la langue d'origine dans la barre d'onglets des traductions.

3. Rédigez le contenu dans la langue d'origine.
         Translate procedure - Source content.png

Étape 2 : Traduction du contenu de l'objet dans la langue cible

1. Cliquez sur la langue cible dans la barre d'onglets des traductions.
Le texte de la langue d'origine est automatiquement inséré.
         Translate procedure - Destination content.png

2. Cliquez sur le menu Affichage puis sur l'icône Translate icon.png.
La langue d'origine est automatiquement détectée.

3. Sélectionnez la langue cible.

4. Cliquez sur Traduire.
Le texte de la procédure est automatiquement traduit dans la langue cible.

5. Effectuez les ajustements nécessaires sur la traduction automatique du texte.

Tags :

Raccourcis

Portail client

Tous les changements
•  Service Manager
•  Service Apps
•  Self Help
•  Service Bots

Powered by XWiki © EasyVista 2022