Self Help Desktop Studio - The Publish Mode

Last modified on 2022/11/21 10:41

Publish mode is used to access the published versions of Self Help projects in the current domain.

It provides a set of panes where you can:

  • Organize Self Help projects.
  • Manage aliases.
  • Manage access rights to published Self Help projects.
  • Generate a link to a Self Help customer portal.
  • Create a new version of a published Self Help project.
  • Manage the recycle bin of the current domain.

Notes

  • Version numbering is automatic and is used to identify the type of version.
    • Major version: Planned version
    • Minor version: Correction of errors and bugs
           example  Major version V3.0, Minor version V2.1
  • You can create a version only from an active version of the Self Help project.
  • You can activate and deactivate published versions individually.
  • You can access and modify unpublished versions in edit mode.

Best Practice

Menu access

Desktop Studio > Mode > Publish

Screens description

     Studio mode - Publish.png

In the standard configuration, publish mode displays three zones:

  • (1) Title bar and menu bar
  • (2) Explorer pane used to access functionalities for published Self Help projects
  • (3) Details pane used to access the details of the element you select in the Explorer pane

Title bar and menu bar

     Studio - Bars.png

(1) Title bar: Information on the current Self Help session, i.e. server name, domain, logged-in user.

(2) Menu bar (Note: Certain menu options can also be accessed via a contextual menu specific to components in the Explorer pane).

Description of the menu bar

File menu: Commands used to:

  • Refresh the page.
  • Access scheduled executions.
  • Find a resource.
  • Import an archive to the domain or export a Self Help project to an archive.
  • Modify the email address and password of the writer logged in to the Desktop Studio.
  • Change the domain.
BarsDescription_EditMenu

Edit menu: Commands used to:

  • Undo and redo modifications.
  • Copy and paste text.
  • Rename and delete objects.
BarsDescription_ViewMenu

View menu: List of views available in the Explorer pane and Description pane.

  • Click one of views to show or hide it.
  • Select Reset Views in the menu to return to the default display mode.
BarsDescription_ModeMenu

Mode menu: List of modes available in the Desktop Studio. The active mode is highlighted by an icon displayed on a blue background.

  • Edit mode: Access all Self Help project versions currently being edited in the current domain. Open url.png See the description
  • Publish mode: Access all published Self Help project versions in the current domain. Open url.png See the description
  • Admin mode (Note: Only for domain administrators and owners of Self Help projects). Open url.png See the description
  • Web Studio: Access the Online Studio.
BarsDescription_HelpMenu

Help menu: Commands used to:

  • Access documentation containing step-by-step procedures on how the Desktop Studio works. Open url.png See the description
  • Return to the Self Help Home page.
  • Define preferences:
    • Display the users created by SSO in the list of users using the Admin configuration option (Note: Functionality available only to domain administrators and system administrators).
    • Select languages for translation.
    • Select programs for opening documents if they are different from those used by the operating system.
    • Define the default configuration of macros.
  • Display the error log.
  • View the server version and the Desktop Studio version.

Explorer pane

It displays all of the functionalities associated with Self Help projects in the current domain whose versions have been published.

To display the pane: Select View > Explorer in the menu

  • Click one of the elements displayed in the pane to access additional properties and functionalities in the Details pane.
         Publication - Explorator Pane.png

Toolbar

  • Select language drop down.png: Used to select the language for displaying components in the Explorer pane.
    • To add a language to the list, select Help > Preferences > Allowed Languages.

Functionalities

Option     Description
Alias This displays the list of aliases associated with published components on the Self Help server, i.e. procedure aliases, project aliases, reserved aliases. Open url.png See the description
  • Aliases can only be associated with Self Help projects or procedures.
  • Reserved aliases can only be associated with procedures.
  • The name of the alias must be unique in each domain and in each version.
  • You can access the list of aliases in the Details pane or click Tree expand icon.png to expand the tree structure.
Published projects This displays all published Self Help projects in the current domain in a tree structure.
  • Double-click the name of the Self Help project or click Tree expand icon.png to expand the tree structure.
    • Components are grouped in folders.
    • The icon displayed next to each component indicates the type of component, e.g. procedure, variable, form, etc. Open url.png See Contents of Self Help projects
  • The version of the Self Help project is indicated between brackets after the name.
  • The icon next to the version name indicates the following:
    • Property OK icon.png: Active version
    • Property NOK icon.png: Inactive version
  • Active versions:
    • Can be accessed via a URL sent to users in publication groups.
    • Are used to generate new working versions, i.e. minor or major.
  • Right-click one of the components to open a contextual menu displaying authorized actions, e.g. create, copy move, import, etc.
  • Right-click one of the versions to create a minor or major revision.
Scheduled executions This displays the list of scheduled executions on the Self Help server.
User groups This displays the list of user groups authorized to access the current domain.
Skins This displays the list of active skins in the current domain.
Domain recycle bin The recycle bin contains the published Self Help project versions that were deleted from the current domain.

Details pane

      Publication - Detail Pane.png

(1) Toolbar
(2) Name of the element selected in the Explorer pane
(3) Tab bar specific to the element selected in the Explorer pane

Toolbar

  • The toolbar is specific to the selected tab.
  • Select language drop down.png: Used to select the language for displaying components in the Details pane.

List of tabs

Tabs specific to a procedure alias or reserved alias

List of procedure aliases tab

This displays the list of procedures found on the Self Help server associated with the selected alias, including:

  • Procedures in all published Self Help projects found in all domains on the server, both active and inactive.
  • Procedures from the last Self Help project versions currently being edited.

          Detail Pane - Procedure and reserved alias - Procedure alias tab.png

  • Select the name of the procedure to display it.
    • Only procedures found in domains accessible to logged-in users will appear.
    • If the procedure is found in a Self Help project currently being edited, the Desktop Studio will automatically switch to edit mode.
  • Click Delete red cross icon.png next to the procedure to dissociate it from the alias.
     

Used by tab

Note: This tab will appear only for procedure aliases.

This displays the list of procedures that call the selected alias, including:

  • Procedures in Self Help projects that are currently being edited.
  • Procedures in published Self Help projects found in all domains on the server, both active and inactive.

          Detail Pane - Procedure and reserved alias - Used by tab.png

  • Select the name of the procedure to display it.
    • Only procedures accessible to logged-in users will appear.
    • If the procedure is found in a Self Help project currently being edited, the Desktop Studio will automatically switch to edit mode.
  • Click Delete red cross icon.png next to the procedure to dissociate it from the alias.

Tabs specific to a project alias

List of project aliases tab

This displays the list of Self Help projects found on the Self Help server associated with the selected alias, including:

  • Published Self Help projects found in all domains on the server, both active and inactive.
  • The last Self Help project versions currently being edited.

          Detail Pane - Project alias - Project alias tab.png

  • Select the Self Help project name to display it.
    • Only Self Help projects found in domains accessible to logged-in users will appear.
    • If the Self Help project is currently being edited, the Desktop Studio will automatically switch to edit mode.
  • Click Delete red cross icon.png next to the Self Help project to dissociate it from the alias.

Tabs specific to published projects

Info tab

Information on the published Self Help project: Title, publication version or working version used to publish the project, description (modifiable field), alias (modifiable field), ID of the writer who published the project, as well as the creation, last modification, publication and indexation dates and times.

          Detail Pane - Published project - Info tab.png

  • Reactivate version icon.png: Used to reactivate a deactivated version of the Self Help project.
  • Disable version icon.png: Used to deactivate an active version of the Self Help project.
     

User groups tab

List of user groups authorized to access the published Self Help project version.

          Detail Pane - Published project - User group tab.png

  • Add group to projet version icon.png: Used to allow access to a new user group.
  • Delete all groups to project version icon.png: Used to prohibit access to all user groups.
     

Quota tab

This displays the following:

  • Disk space used by the Self Help project version.
  • Disk space used by other Self Help projects.
  • Disk space available on the Self Help server (Note: Except if the server has unlimited disk space).

          Detail Pane - Published project - Quota tab.png
 

Statistics tab

Statistics on the use of each procedure in the Self Help project: e.g. number of executions and their average duration, average number of steps in the procedure, etc.

          Detail Pane - Published project - Statistics tab.png

  • Open procedure execution icon.png: Used to open a procedure instance.

Tabs specific to procedures in published projects

Info tab

Information on the procedure, i.e. creation date, last modification date, location, and the list of metadata, both general and specific to the type of procedure.

          Detail Pane - Published project procedure - Info tab.png

  • Authorize to launch procedure icon.png: Used to authorize end users to run the procedure directly.
  • Prohibit to launch procedure icon.png: Used to prohibit end users from running the procedure directly.
     

Statistics tab

Statistics on the use of the selected procedure.

          Detail Pane - Published project procedure - Statistics tab.png

  • Open procedure execution icon.png: Used to open a procedure instance.

Tabs specific to user groups

Accessible versions tab

List of Self Help projects that the user group is authorized to access.

          Detail Pane - User group - Accessible version tab.png

  • For the selected user group, you should select or unselect the functionalities in each version that you want to show or hide in the procedure toolbar on the Self Help customer portal. Open url.png See the procedure
  • Click Delete red cross icon.png next to the Self Help project to remove the user group's access to it.
     

User group members tab

List of users belonging to the selected user group.

          Detail Pane - User group - Member tab.png

  • Click one of the email addresses to send a message to the user.

Procedures

How to create a new Self Help project version

Step 1: Create a new minor or major version

1. Access the Studio in publish mode by selecting Mode > Publish in the menu.

2. Expand the tree structure of the Self Help project by clicking Tree expand icon.png in the Explorer pane.

3. Right-click an active version of the Self Help project, indicated by the Property OK icon.png icon, and select Create a new minor version from the contextual menu.

The Edit new version action dialog box will appear.
 

Step 2: Specify scheduling information on the version

  • You can click Execute now to create the version immediately.
  • You can click Delay execution at to schedule a later date and time for creating the version.

The new version will appear in the Explorer pane.

How to generate a link to the Self Help customer portal

Step 1: Access the window for configuring the link

1. Access the Studio in publish mode by selecting Mode > Publish in the menu.

2. Expand the tree structure of the Self Help project by clicking Tree expand icon.png in the Explorer pane.

3. Right-click the active version of the Self Help project and select Generate a portal link from the contextual menu.

The window for configuring the link will appear.
      Generate portal link.png
 

Step 2: Generate the link

1. Specify the parameters of the link.

  • Choose skin: Select the skin for displaying the portal.
  • Select the Custom portal box.
  • If you want the portal login page to appear, select Show Login page. If you want users to access the list of Self Help projects on the portal directly, select Auto login.
    • If you select Auto login, you should select the public user from the User drop-down list in order to enable direct access to the portal. Note: All users will be identified using this name.
  •  Selected project: Select the Self Help project to appear by default when the portal is run.
  • Select the options you want.
    • Cannot select another project: Used to prevent users from opening a Self Help project other than the one displayed by default when the portal is run.
    • Use last project version: Used to display the last published Self Help project version opened by default when the portal is run. This must be accessible to the logged-in user, i.e. the user must belong to a group associated with this version.
    • Restrict alias redirection to published resources: Used to indicate that the portal can only use aliases in published versions.
    • Use the alias of this element in the generated link (Note: Accessible only if a project alias was defined): Used to replace the ID of the Self Help project with its alias in the generated link.
  • Portal exit: Select the relevant outcome when users exit the portal.
    • Go to the Login page: Users will return to the portal login page.
    • Go to the last page before the portal: Users will return to the last page viewed before accessing the portal.
    • Go to this URL: Enter the URL to which you want to redirect users. Note: If you do not specify a URL, users will return to the portal login page.

The link to the portal will appear in the Generated link field. You can copy it, run it in a Web browser or save it.

2. Click Launch the portal.

The portal will appear in the default Web browser.

3. Click Finish.

Tags:
Powered by XWiki © EasyVista 2024