Self Help Desktop Studio - The Edit Mode

Last modified on 2023/09/22 10:09

Edit mode in the Desktop Studio is used to access unpublished versions of Self Help projects in the current domain.

It is made up of several panes enabling you to:

Notes

  • Customers can customize the standard configuration of panes in edit mode in the Desktop Studio.
  • Self Help multilingual management enables you to translate the components in each Self Help project into different languages, e.g. translation of component names, procedures, forms, etc.
  • Once the version of a Self Help project is published, it can no longer be modified. You can access it in publish mode.
      Open url.png See Version management

Best Practice

  • Move the panes to the spot you want.
  • You can also modify the default size of the panes:
    • Explorer pane: 1/3 of the screen width.
    • Conception pane: 2/3 of the screen width and 1/3 of the screen height.
    • Description pane: 2/3 of the screen width and screen height.
  • Select View > Reset Views in the menu to return to the default display mode.

Menu access

Desktop Studio > Mode > Edit

Screens description

      Studio mode - Edit.png

In the standard configuration, edit mode in the Desktop Studio displays four zones:

  • (1) Title bar and menu bar.
  • (2) Explorer pane with a view bar at the top that is used to:
    • Manage Self Help project versions and components in the current domain via the tree structure. 
    • Define the properties of components.
    • Access an overview of the current procedure.
  • (3) Conception pane with a workspace for designing procedures, HTML content and forms.
  • (4) Description pane specific to the object selected in the Conception pane, used to define its content and layout and manage the resources used.

Title bar and menu bar

     Studio - Bars.png

(1) Title bar: Information on the current Self Help session, i.e. server name, domain, logged-in user.

(2) Menu bar (Note: Certain menu options can also be accessed via a contextual menu specific to components in the Explorer pane).

Description of the menu bar

BarsDescription_FileMenu

File menu: Commands used to:

  • Create a new object.
  • Import an archive to the domain or export a Self Help project to an archive.
  • Publish a Self Help project.
  • Modify the email address and password of the writer logged in to the Desktop Studio.
  • Change the domain.
EndBarsDescription_FileMenu
BarsDescription_EditMenu

Edit menu: Commands used to:

  • Undo and redo modifications.
  • Copy and paste text.
  • Rename and delete objects.
EndBarsDescription_EditMenu
BarsDescription_ProcedureMenu

Procedure menu (Note: Only if a procedure is displayed in the Conception pane): Commands for performing actions on the steps of a procedure.

EndBarsDescription_ProcedureMenu
BarsDescription_ViewMenu

View menu: List of views available in the Explorer pane and Description pane.

  • Click one of views to show or hide it.
  • Select Reset Views in the menu to return to the default display mode.
EndBarsDescription_ViewMenu
  • The active view is highlighted by an icon displayed on a blue background.
  • The Explorer pane includes three views: Explorer, Properties and Overview.
  • The Description pane includes one view for each language available for the current Self Help project. Open url.png See the description
BarsDescription_ModeMenu

Mode menu: List of modes available in the Desktop Studio. The active mode is highlighted by an icon displayed on a blue background.

  • Edit mode: Access all Self Help project versions currently being edited in the current domain. Open url.png See the description
  • Publish mode: Access all published Self Help project versions in the current domain. Open url.png See the description
  • Admin mode (Note: Only for domain administrators and owners of Self Help projects). Open url.png See the description
  • Web Studio: Access the Online Studio.
EndBarsDescription_ModeMenu
BarsDescription_HelpMenu

Help menu: Commands used to:

  • Access documentation containing step-by-step procedures on how the Desktop Studio works. Open url.png See the description
  • Return to the Self Help Home page.
  • Define preferences:
    • Display the users created by SSO in the list of users using the Admin configuration option (Note: Functionality available only to domain administrators and system administrators).
    • Select languages for translation.
    • Select programs for opening documents if they are different from those used by the operating system.
    • Define the default configuration of macros.
  • Display the error log.
  • View the server version and the Desktop Studio version.
EndBarsDescription_HelpMenu

Explorer pane

The Explorer pane is made up of several zones.

  • (1) View bar: Explorer, Properties for projects, procedures and resources, and Overview for procedures only.
  • (2) Contextual toolbar specific to the selected view.
  • (3) Pane for displaying information specific to the selected view.

        Explorer Pane.png

Explorer view

This view displays all Self Help projects in the current domain in a tree structure.

To show or hide the view: View > Explorer in the menu

        Explorer Pane - Explorer view.png

Toolbar

  • Status icon.png: Used to display the list of statuses applicable to resources and procedures.
    • The status changes as the workflow progresses: Draft, To be approved, Rework, Approved, Published.
    • The initial status for all content created in a Self Help project is Draft.
    • The status of all content imported from a Self Help project can be kept (i.e. status saved in the archive), or initialized using one of the workflow statuses.
        Open url.png See the description of the content validation workflow
       
    • Click Show status or Hide status to respectively show or hide the status of the component.
             Content validation workflow - Status display via Explorer pane.png
      Note: You can also see the status in the Properties view > Info tab.
    • Click one of the statuses in the list to display only the content associated with the status.
       
  • Select language drop down.png: Used to select the language for displaying the names of components in the tree structure.
    • To add a language to the list, select Help > Preferences > Allowed Languages.
       
  • Synchronize icon.png: Used to refresh the Conception pane based on the component selected in the tree structure.
  • Minimize maximize icon.png: Used to minimize the Explorer view or to display it in Full screen mode. When minimized, icons will appear in a left sidebar.

Tree structure

It displays all of the components for a given Self Help project, i.e. folders, procedures, resources, etc.
       Explorer Pane - Explorer view - Tree.png

  • The current version of each Self Help project is indicated between brackets after the name.
    Note: You can access previously published versions in publish mode.
  • Click Tree expand icon.png or double-click the project name to display the tree structure of the Self Help project.
    • To make them easier to manage, you can group components in folders, e.g. Resources, Examples, etc.
    • The icon displayed next to each component indicates the type of component, e.g. procedure, variable, form, etc.
    • The User procedure access icon.png icon displayed after a procedure name indicates that it can be accessed by end users.
    • Right-click a component to display its contextual menu. A list of the actions authorized will appear, e.g. create, copy, move, import, etc.
  • To modify the component name, right-click the name and select Rename.
    • To translate a component name, you should first click Select language drop down.png in the toolbar to select the language. Open url.png See Self Help multilingual management
      Note: The word <sans nom> displayed next to a component shows that no translation is available. The name between brackets is the one in the Desktop Studio display language.
             Explorer Pane - Explorer view - Component with no translated label.png

Properties view

This view displays general information and metadata for the component selected in the tree structure of the Explorer pane.

To show or hide the view: View > Properties in the menu

Properties view specific to Self Help projects

      Explorer Pane - Properties view - Project.png

Toolbar

  • Select language drop down.png: Used to select the language for displaying the content of properties for the Self Help project.
     

Title bar

  • Double-click the Self Help project name to modify it.
    • You can also modify the name via the tree structure. Right-click the Self Help project and select Rename.
    • To translate the name, you should click Select language drop down.png to select the language.
  • The Warning icon.png icon will be displayed if the Self Help project has no name.
     
ExplorerPane_ProjectPropertiesView_Tabs

List of tabs

  • Info: Information on the Self Help project, i.e. last version number and its origin, last modification date, etc. Note: You cannot modify this information.
  • Quota: This displays the following:
    • Disk space used by the Self Help project version.
    • Disk space used by other Self Help projects.
    • Disk space available on the server (Note: Except if the server has unlimited disk space).
  • Metadata Definition: List of active metadata manually added to the Self Help project.
    • You can export active items of metadata. They apply to all Self Help project procedures. Open url.png See How to export metadata from a Self Help project
    • Click Add metadata icon.png in the toolbar to add an item of metadata.
    • You can click Activate metadata icon.png to deactivate an item of metadata. It will automatically be moved to the Deactivated Metadata tab.
  • Deactivated Metadata: List of deactivated metadata manually added to the Self Help project.
    • You cannot export deactivated items of metadata.
    • You can click Activate metadata icon.png to reactivate an item of metadata. It will automatically be moved to the Metadata Definition tab.
  • Statistics: Statistics on the use of each procedure in the Self Help project, e.g. number of executions and their average duration, average number of steps in the procedure, etc.  - Open url.png See the procedure
EndExplorerPane_ProjectPropertiesView_Tabs

 

Properties view specific to procedures

      Explorer Pane - Properties view - Procedure.png

Toolbar

  • Select language drop down.png: Used to select the language for displaying the content of properties for the procedure.
  • Open procedure icon.png: Used to open the procedure in the Conception pane.
  • Access procedure icon.png No access procedure icon.png: Used to indicate whether or not users are authorized to run the procedure directly. Click the icon to toggle from one status to another.
     

Title bar

  • Double-click the procedure name to modify it.
    • You can also modify the name via the tree structure. Right-click the procedure and select Rename.
    • To translate the name, you should click Select language drop down.png to select the language.
  • The Warning icon.png icon will be displayed if the procedure has no name.
     
ExplorerPane_ProcedurePropertiesView_Tabs

List of tabs

  • Info: Information on the procedure, i.e. creation date, last modification date, location, and the list of metadata, both general and specific to the type of procedure.
    • Double-click one of the properties to specify it. Note: You cannot modify general information.
    • You can export items of metadata. Open url.png See How to export metadata from a Self Help project
    • To specify input and output parameters for the procedure, click Parameters > Edit parameters.
    • Click Link > Click to generate a link to generate the URL and test the procedure in a Web browser.
    • Click Icon > Add icon to procedure icon.png to associate an icon with the procedure.
  • Uses: List of resources used by the procedure.
    • Click <Open procedure and show the steps this resource is linked to>. The Conception pane will display the procedure and the list of resources used by the procedure. Click one of the resources to highlight it in the Conception pane.
  • Used by: List of resources using the procedure.
    • Click <Open procedure and show the steps this resource is linked to>. The Conception pane will display the procedure and the list of resources using the procedure. Click one of the resources to highlight it in the Conception pane.
  • Statistics: Statistics on the use of the procedure, e.g. number of executions and their average duration, average number of steps in the procedure, etc.  - Open url.png See the procedure
    • Click Open procedure execution icon.png in the toolbar to open a specific procedure instance.
EndExplorerPane_ProcedurePropertiesView_Tabs

 

Properties view specific to resources

      Explorer Pane - Properties view - Resource.png

Toolbar

  • Select language drop down.png: Used to select the language for displaying the content of properties for the resource.
  • Open object icon.png: Used to open the resource.
    • HTML content, Form, Sub-procedure resources: Content is displayed in the Conception pane.
    • Link resources: The URL is displayed in the Conception pane.
    • Document resources: These are opened using the corresponding program, e.g. Excel, Word, Paint, etc.
       
  • Document resources:
    • Replace file icon.png: Used to select a new file. Its content will automatically be propagated to the places where it is used in the project.
    • Download file icon.png: Used to download the file.
       

Title bar

  • Double-click the resource name to modify it.
    • You can also modify the name via the tree structure. Right-click the resource and select Rename.
    • To translate the name, you should click Select language drop down.png to select the language.
  • The Warning icon.png icon will be displayed if the resource has no name.
     
ExplorerPane_ResourcePropertiesView_Tabs

List of tabs

  • Info: Information on the resource, i.e. creation date, last modification date, location, size, etc. Note: You cannot modify this information.
  • Linked Resources (Note: Only for HTML content resources): List of resources linked to the resource.
  • Variable (Note: Only for Form resources): Properties of the variable.
    • Click the link to display the steps where the variable is used.
  • Used by: List of steps using the resource, for each procedure.
    • Click <Open procedure and show the steps this resource is linked to>. The list of steps using the resource will appear for each procedure. Click one of the steps to display the procedure in the Conception pane and highlight the step.
EndExplorerPane_ResourcePropertiesView_Tabs

Overview view

This view displays the flow chart of the procedure selected in the tree structure.

Best Practice icon.png  Use this view to display an overview of lengthy procedures that require horizontal scrolling in the Conception pane.

To show or hide the view: View > Overview in the menu

        Explorer Pane - Overview view.png

Toolbar

  • Zoom: Used to adjust the zoom level for the flow chart displayed.
    • The red outline indicates the area displayed in the Conception pane.
    • Click and drag the outline to view the area you want in the Conception pane.
       
  • Overview Page icon.png: Used to adjust the zoom level automatically so that the flow chart is fully displayed in the Conception pane without requiring any scroll bars.
  • Overview Height icon.png: Used to adjust the zoom level automatically so that the height of the flow chart is fully displayed without requiring the vertical scroll bar.
  • Overview Width icon.png: Used to adjust the zoom level automatically so that the width of the flow chart is fully displayed without requiring the horizontal scroll bar.

Conception pane

The Conception pane is used to design three types of components, i.e. procedures, HTML content resources, and Form resources.

  • When you access the Desktop Studio in edit mode, the component displayed is the one last opened during the previous Self Help session.
  • The tab bar at the top of the pane displays the history of components previously opened in the Conception pane, irrespective of the Self Help project.
           Conception Pane - Component tabs.png
    • Select a tab to display the component in the workspace.
    • Click >> au bout de la barre pour afficher la liste des composants non visibles (le nombre est indiqué derrière l'icône)..

Best Practice icon.png  Click Synchronize icon.png in the Explorer view to refresh the tree structure automatically each time you open one of the components in a tab.

Conception pane specific to procedures

This pane enables you to design the flow chart for the current procedure by configuring each of its steps.
       Open url.png See How to create a procedure

It is made up of several zones.

  • (1) Tab bar of previously opened components
  • (2) Toolbar
  • (3) Space for designing the procedure

        Conception Pane - Procedure.png

Best Practice

  • If the length of a procedure exceeds the width of the screen, select the Overview view in the Explorer pane to display the entire flow chart. You can then use the zoom to adjust the size of the flow chart.

Workspace

It is used to build the decision tree for the current procedure.

  • Click one of the steps to select it. A blue outline will appear.
           Conception Pane - Procedure - Active step.png
    • The toolbars in the Conception and Description panes will be refreshed based on the type of step you select.
    • Define the configuration and layout in the Description pane.
       
  • Icons displayed within the outline of a step show the type of resource used, e.g. form, document, etc.
           Conception Pane - Procedure - Step with resources.png
    • To associate a resource with a step, click and drag the resource from the tree structure of the Explorer pane to the outline of the relevant step in the Conception pane. The tab specific to the type of resource will automatically be refreshed in the Description pane.
             Conception Pane - Procedure - Drag and drop resource.png
    • You can also insert resources directly in the Description pane.
       
  • Double-click one of the steps to specify its name.
    • You can hide part of the name by placing the text to be hidden within square brackets  [ ].
    • You can also enter the name in the title bar of the Description pane.
       
  • Warning icon.png Used to indicate that errors were detected, e.g. name not specified, error in a condition, etc. Move the cursor over the icon to display its details in a tooltip.
           Conception Pane - Procedure - Step with problem.png

Conception pane specific to HTML content resources

This pane enables you to enter text and define the layout for a HTML content page.
Note: Unlike in procedure steps, the Description pane is not used.

It is made up of several zones.

  • (1) Tab bar of previously opened components
  • (2) Toolbar
  • (3) Space for designing HTML content

        Conception Pane - Html content.png

Workspace

  • Enter the text directly in the workspace.
  • To add a resource:
    • Click and drag the resource from the tree structure of the Explorer pane to the workspace.
    • Once the resource is added to the workspace, click it to display the configuration options.
             Conception Pane - Html content - Resource contextual menu.png
  • Use the toolbars and menus to format the text.Open url.png See the Content tab in the Description pane

Conception pane specific to Form resources

This pane enables you to design the current form by configuring each of its fields.

It is made up of several zones.

  • (1) Tab bar of previously opened components
  • (2) Toolbar
  • (3) Space for designing the form

        Conception Pane - Formulaire.png

Workspace

It is used to build the contents of the current form.

  • To add a row or column to the form, click Add icon.png at the bottom or to the right of the form respectively.
  • To add a field, right-click the new row or column and select Add from the contextual menu.
  • Click one of the fields to select it. A blue outline will appear.
           Conception Pane - Formulaire - Active field.png
    • The toolbars in the Conception and Description panes will be refreshed based on the type of field you select.
    • Define the configuration and layout in the Description pane.
       
  • Double-click the title bar of the field in the Description pane to specify its name.
    • You can hide part of the name by placing the text to be hidden within square brackets  [ ].
  • Warning icon.png Used to indicate that errors were detected, e.g. name not specified, error in a condition, etc. Move the cursor over the icon to display its details in a tooltip.
           Conception Pane - Formulaire - Field with problem.png

Description pane

The Description pane enables you to define the contents of the object you select in the Conception pane, e.g. procedure step or form field.

Description pane specific to procedure steps

This pane enables you to enter the content of the step, define its layout and specify the resources used.
       Open url.png See How to create a procedure

It is made up of several zones.

  • (1) Tab bar displaying the translations of the step's contents
  • (2) Title bar
  • (3) Tab bar
  • (4) Contextual toolbar specific to the current tab
  • (5) Space for defining the contents of the current tab

        Description Pane - Procedure.png

Translation tab bar

        Description Pane - Procedure - Translation tabs.png

  • One tab is displayed for each language in the Self Help project whose view you opened by selecting View > Description (language) in the menu.
  • When you add a new language to the Self Help project, the contents from the tab of the source language will automatically be copied to the tab of the new language.
    • Use the automatic translation tool to translate the text into the new language. Open url.png See the procedure 
    • To add a language to the Self Help project, select Help > Preferences > Allowed Languages in the menu.
  • Each language can have its own content, layout and resources.

Title bar

  • Double-click the name of the step to modify it.
    • You can hide part of the name by placing the text to be hidden within square brackets  [ ].
    • You can also double-click the step in the Conception pane to modify its name.
  • The Warning icon.png icon will be displayed if the step has no name in the selected language.
           Description Pane - Procedure - Component with no title.png

List of tabs

        Description Pane - Procedure - Tabs.png

  • Each tab has a contextual toolbar.
  • The resources associated with each step are displayed in dedicated tabs.
    Note: An icon indicating the type of resource is also displayed in the outline of the step in the Conception pane.

example  Step with a Connector resource and a Document resource

  • Resources are displayed in the Connectors and Linked documents tabs.
  • The corresponding icons are displayed in the outline of the step. Conception Pane - Procedure - Step with resources.png
  • To add a resource to one of the tabs, click and drag it from the tree structure of the Explorer pane to the relevant tab.
           Description Pane - Procedure - Drag and drop resource.png


Content tab

Editor for defining the HTML content of the object and its layout, e.g. text, tables, links, resources, etc.
Note: This tab appears only for Action, Action with Switch, Branch, Page and Page with Choices steps.

        Description Pane - Procedure - Content tab.png

  • Icons are grouped in menus based on their functionality.
    • Home menu: Functions for formatting text, e.g. font, bold, underlined, bullets, alignment, etc.
    • Insert menu: Functions for inserting resources, e.g. Self Help project resources, layout zones, horizontal lines, special characters or icons from the icon gallery.
    • Layout menu: Functions for defining the layout of content, e.g. layout templates, image or text layout zones, etc.
        Open url.png See How to use layout zones
    • View menu: Zoom, automatic translation tool, printing, HTML code editor, keyboard shortcuts.
        Open url.png See How to use the automatic translation tool
  • To insert a resource in the editor:
    • Click and drag the resource from the tree structure of the Explorer pane to the Content tab.
    • Click the name to configure it using the contextual toolbar.
  • To define clickable areas for images:
    • Click Clickable image icon.png in the contextual toolbar of the image.
    • Define the areas that will run an action when users click them, e.g. open a Web page, go to the next step, redirect to a branch of the tree, etc.  - Open url.png See the procedure
       

Linked documents tab

List of Document resources used in the current step, e.g. image, audio or video files, PDFs, etc.
Note: This tab appears only for Action, Action with Switch, Page and Page with Choices steps.

        Description Pane - Procedure - Link Files tab.png
 

Forms tab

List of Form resources used by the current step.
Note: This tab appears only for Action, Action with Switch, Page and Page with Choices steps.

        Description Pane - Procedure - Forms tab.png

  • Display colors:
    • Red: Parameters
    • Blue: Variables
       

Branches tab

List of branches linked to the step.
Note: This tab appears only for Action, Action with Switch, Page and Page with Choices steps.

        Description Pane - Procedure - Branches tab.png

Connectors tab

List of connectors used by the current step with their parameters and variables.
Note: This tab appears only for Action, Action with Switch, Page and Page with Choices steps.

        Description Pane - Procedure - Connectors tab.png

  • Display colors:
    • Green: Connectors attached to the object via the Conception pane
    • Blue: Connectors inserted in the step content via the Description pane
       

Linked procedure tab

List of sub-procedures used by the current step.
Note: This tab appears only for Sub-procedure steps.

         Description Pane - Procedure - Related procedures tab.png

Linked Go to steps tab

List of markers inserted in the current step.
Note: This tab appears only for Marker steps.

        Description Pane - Procedure - Related resume points tab.png

Report tab

Text inserted in the execution report when users run the current step. This is not visible in the Web page.
The execution report describes the user journey in the procedure, i.e. all of the steps and branches consulted. It can be defined for each step via this tab.

  • By default, the report contains the name of the step.
  • You can customize the report for the current step using three options:
    • Custom Report: Enter the text to be inserted in the report manually.
    • Step title report: The name of the current step is automatically inserted in the report.
    • None: No text is displayed in the report.

Best Practice icon.png  Add a report to steps in a procedure when you want to see what users choose to do.

Macro tab

Editor for defining macros.
Note: This tab appears for all steps, except Branch steps.

        Description Pane - Procedure - Macro tab.png

Best Practice icon.png  Use macros to run calculations or to modify the user journey based on the user's answers in forms.

Description pane specific to form fields

This pane enables you to enter the contents of a field, define its layout, specify display conditions and input and output variables.

It is made up of several zones.

  • (1) Tab bar displaying the translations of the field's contents
  • (2) Title bar
  • (3) Tab bar
  • (4) Space for defining the contents of the current tab

        Description Pane - Formulaire.png

List of tabs

        Description Pane - Formulaire - Tabs.png

Display tab

        Description Pane - Formulaire - Display tab.png
 

Type and Validation tab

        Description Pane - Formulaire - Type validation tab.png

Input/Output tab

        Description Pane - Formulaire - Input output tab.png

Layout zones

Layout zones enable you to:

  • Define the appearance and behavior of the content zones in a visible step depending on the device used to access them, e.g. PC, smartphone, etc. For example, you can define zones to display text or images, or define the size of these zones.
  • Display the Self Help project title, procedure title and step title in the page body.

Notes

  • A template library is shipped with the standard Self Help project. You can add your own templates.
    *By default, these zones are responsive in design.

Example

Template with three zones: 

  • (1): Heading zone
  • (2): Image zone
  • (3): Text zone

          Layout zones - Example.png

Access

Description pane > Content tab > Layout menu

Description

          Layout zones.png

(1): Used to display layout templates
       Layout zones - Predefined templates.png

(2): Used to configure the type of zone
       example  H6 heading

          Layout zones - Predefined zones.png

Procedure: How to use layout zones

Step 1: Select the layout template

1. Go to the Description pane. Select the Content tab and click Layout in the menu.

2. Click Layout zones icon.png.

3. Click the predefined template you want, e.g. D1, D2, etc.
       Layout zones - Standard.png

4. In the Headlines section, click the number of headings you want to insert in the page.

Caution: Text placed within square brackets  [ ] in each heading will not be hidden when the procedure is run.

  • Number of headings = 1 ==> The name of the current step will automatically be inserted in the page contents as heading H1.
          Layout zones - One headline.png
  • Number of headings = 2 ==> The names of the procedure and current step will automatically be inserted in the page contents as headings H1 and H2.
          Layout zones - Two headlines.png
  • Number of headings = 3 ==> The names of the project, procedure and current step will automatically be inserted in the page contents as headings H1,H2 and H3.
          Layout zones - Three headlines.png
     

Step 2 (optional): Customize the template

1. Complete the layout by inserting other zones.

        Layout zones - Customize.png

  • (1) Insert a zone to the left of, inside, or to the right of the zone where the cursor is currently found.
  • (2) Left align or right align the zone.
  • (3) Width of the zone.
  • (4) Default initial content of the zone, i.e. empty, or displaying the project name, procedure name or step name.

Examples

Heading zones

Display headings
       Layout zones - Example - Title zones configuration.png

Self Help Example
Layout zones - Example - Title zones in Self Help.png Layout zones - Example - Title zones result.png

Text zones

Display text and lists
       Layout zones - Example - Text zones configuration.png

Self Help Example
Layout zones - Example - Text zones in Self Help.png Layout zones - Example - Text zones result.png

Resource zones

Display an image, video and link
       Layout zones - Example - Resource zones configuration.png

Self Help Example
Layout zones - Example - Resource zones in Self Help.png Layout zones - Example - Resource zones result.png
Tags:
Powered by XWiki © EasyVista 2024